aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/himenobench/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/himenobench/Makefile')
-rw-r--r--benchmarks/himenobench/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/benchmarks/himenobench/Makefile b/benchmarks/himenobench/Makefile
index 318f907ab3f1..f105aa3f2371 100644
--- a/benchmarks/himenobench/Makefile
+++ b/benchmarks/himenobench/Makefile
@@ -29,7 +29,7 @@ RESTRICTED= "unsure to redistribute"
.if defined(WITH_OPTIMIZED_FLAGS)
FFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations
CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations
-.if (${ARCH} == "i386" && !${ARCH}== "amd64")
+.if (${MACHINE_ARCH} == "i386" && !${MACHINE_ARCH}== "amd64")
FFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3 -malign-double
CFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3 -malign-double
.endif # i386