aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/httperf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/httperf/Makefile')
-rw-r--r--benchmarks/httperf/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/benchmarks/httperf/Makefile b/benchmarks/httperf/Makefile
index 4d5ecc18b8dd..36c8e38b03e0 100644
--- a/benchmarks/httperf/Makefile
+++ b/benchmarks/httperf/Makefile
@@ -16,13 +16,20 @@ COMMENT= A tool for measuring webserver performance
USE_OPENSSL= yes
USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MAKE_ARGS= LIBUTIL_OBJS=ssl_writev.o \
+ exec_prefix=${PREFIX}
+PLIST_FILES= bin/httperf
+.if !defined(NOPORTDOCS)
+PORTDOCS= ChangeLog NEWS README TODO
+.endif
MAN1= httperf.1
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in ChangeLog NEWS README TODO
+.for file in ${PORTDOCS}
${INSTALL_MAN} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif