aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/iorate/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/iorate/Makefile')
-rw-r--r--benchmarks/iorate/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/benchmarks/iorate/Makefile b/benchmarks/iorate/Makefile
new file mode 100644
index 000000000000..7b1ab683b042
--- /dev/null
+++ b/benchmarks/iorate/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= iorate
+PORTVERSION= 3.05
+CATEGORIES= benchmarks
+MASTER_SITES= http://sites.google.com/site/vwiorate/downloads/3-05/
+DISTNAME= iorate-${PORTVERSION}-src
+EXTRACT_SUFX= .tar
+
+MAINTAINER= blttll@gmail.com
+COMMENT= General purpose storage I/O benchmarking tool
+
+USES= bison
+FETCH_ARGS= -Fpr
+MAKEFILE= makefile
+MAKE_ARGS= CC="${CC}"
+NO_WRKSUBDIR= yes
+
+MAN1= ${PORTNAME}.1
+PORTDOCS= README README.versions
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,^CFLAGS ,&+,' ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/iorate ${WRKSRC}/ior_rand ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/cycle ${WRKSRC}/gen_* ${WRKSRC}/run_* \
+ ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.ior ${DATADIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>