aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/iozone/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/iozone/Makefile')
-rw-r--r--benchmarks/iozone/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/benchmarks/iozone/Makefile b/benchmarks/iozone/Makefile
index 146c7004f769..047ff0c21b5b 100644
--- a/benchmarks/iozone/Makefile
+++ b/benchmarks/iozone/Makefile
@@ -27,15 +27,13 @@ ALL_TARGET=
MAN1= iozone.1
PLIST_FILES= bin/iozone
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 500000
OPTIONS= THREADS "Enable threading (uses pthreads)" on
-.endif
+
+.include <bsd.port.pre.mk>
.if defined (WITH_THREADS)
-CFLAGS+= -pthread
-MAKE_ENV= LDFLAGS=-lpthread
+CFLAGS+= ${PTHREAD_CFLAGS}
+MAKE_ENV= LDFLAGS=${PTHREAD_LIBS}
.else
CFLAGS+=-DNO_THREADS
.endif