aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/nttcp
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/nttcp')
-rw-r--r--benchmarks/nttcp/Makefile32
-rw-r--r--benchmarks/nttcp/distinfo1
-rw-r--r--benchmarks/nttcp/files/Makefile184
-rw-r--r--benchmarks/nttcp/files/patch-aa31
-rw-r--r--benchmarks/nttcp/pkg-comment1
-rw-r--r--benchmarks/nttcp/pkg-descr7
-rw-r--r--benchmarks/nttcp/pkg-plist1
7 files changed, 0 insertions, 257 deletions
diff --git a/benchmarks/nttcp/Makefile b/benchmarks/nttcp/Makefile
deleted file mode 100644
index 9c91104ef509..000000000000
--- a/benchmarks/nttcp/Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
-# New ports collection makefile for: nttcp
-# Version required: 1.3
-# Date created: 11 Nov 1998
-# Whom: Bill Fumerola <billf@chc-chimes.com>
-#
-# $FreeBSD$
-#
-
-DISTNAME= nttcp-1.4
-CATEGORIES= net benchmarks
-MASTER_SITES= http://users.leo.org/~bartel/nttcp/ \
- http://www.FreeBSD.org/~billf/
-
-MAINTAINER= billf@FreeBSD.org
-
-ALL_TARGET= nttcp
-MAN1= nttcp.1
-USE_GMAKE= yes
-MAKE_ENV+= CFLG="${CFLAGS}"
-
-post-patch:
-
- @${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.pre_sed
- @${SED} -e 's#-O2#${CFLAGS}#' \
- ${WRKSRC}/Makefile.pre_sed > ${WRKSRC}/Makefile
-
-do-install:
-
- ${INSTALL_PROGRAM} ${WRKSRC}/nttcp ${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/nttcp.1 ${PREFIX}/man/man1/
-
-.include <bsd.port.mk>
diff --git a/benchmarks/nttcp/distinfo b/benchmarks/nttcp/distinfo
deleted file mode 100644
index e311ea60bc7c..000000000000
--- a/benchmarks/nttcp/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (nttcp-1.4.tar.gz) = b97cadd2560c7e06faf890ebe7ceefc2
diff --git a/benchmarks/nttcp/files/Makefile b/benchmarks/nttcp/files/Makefile
deleted file mode 100644
index 4b727c8ac528..000000000000
--- a/benchmarks/nttcp/files/Makefile
+++ /dev/null
@@ -1,184 +0,0 @@
-# This code was written and is copyrighted 1996,1998 by
-#
-# Elmar Bartel
-# Institut fuer Informatik
-# Technische Universitaet Muenchen
-# bartel@informatik.tu-muenchen.de
-#
-# Permission to use, copy, modify and distribute this software
-# and its documentation for any purpose, except making money, is
-# herby granted, provided that the above copyright notice and
-# this permission appears in all places, where this code is
-# referenced or used literally.
-
-# uncomment the settings for your system and type make.
-# if there is no setting available, simply try to use
-# the most closest settings.
-# Finally let me know what you used, to get it running.
-
-
-## For System V4.1 (AT&T) either cc or gcc
-## And for SINIX V4.1 (either mips or intel).
-#ARCH=
-#LIB= -lsocket -lnsl
-#CC= cc
-#OPT= -O
-#DBG= -g
-#INC=
-
-## For DEC (Mips)ULTRIX 4.1
-#ARCH= -Dultrix
-#LIB=
-#CC= gcc
-#OPT= -O2
-#DBG=
-#INC=
-
-## For HPUX 9.* with gcc
-#ARCH= -Dhpux9
-#LIB=
-#CC= gcc
-#OPT= -O2
-#DBG= -g
-#INC=
-
-## For HPUX 9.* with cc
-#ARCH= -Ae -Dhpux9
-#LIB=
-#CC= cc
-#OPT= -O
-#DBG= -g
-#INC=
-
-
-## For HPUX 10.* with gcc
-#ARCH= -Dhpux
-#LIB=
-#CC= gcc
-#OPT= -O2
-#DBG= -g
-#INC=
-
-## For HPUX 10.* with cc
-#ARCH= -Ae -Dhpux
-#LIB=
-#CC= cc
-#OPT= -O
-#DBG= -g
-#INC=
-
-## For SunOS 4.1 with clcc
-#ARCH=-DSunOS4
-#LIB=
-#OPT= -O2
-#CC= clcc
-#DBG=
-#INC=
-
-## For SunOS 4.1 with gcc
-#ARCH=-DSunOS4
-#LIB=
-#OPT= -O2
-#CC= gcc
-#DBG=
-#INC=
-
-## For SunOS 5.3 with gcc
-#ARCH=-DSunOS53
-#LIB= -lsocket -lnsl -lucb
-#OPT= -O2
-#CC= gcc
-#DBG=
-#INC=
-
-## For SunOS 5.[456] with cc from SunSoft
-#ARCH=-DSunOS54
-#LIB= -lsocket -lnsl
-#OPT= -O
-#CC= /usr/ccs/bin/cc
-#CC= /opt/SUNWspro/bin/cc
-#DBG= -g
-#INC=
-
-## For SunOS 5.[456] with gcc
-#ARCH=-DSunOS54
-#LIB= -lsocket -lnsl
-#OPT= -O2
-#CC= gcc
-#DBG= -Wall -g
-#INC=
-
-## For FreeBSD
-ARCH= -DFreeBSD
-LIB=
-OPT= -O2
-CC= cc
-DBG=
-INC=
-
-## For SGI IRIX 5.3, 6.2 (cc or gcc)
-#ARCH=
-#LIB=
-#OPT= -O
-#CC= cc
-#DBG=
-#INC=
-
-## For IBM AIX 2.3
-#ARCH= -Daix
-#LIB=
-#OPT= -O
-#CC= cc
-#DBG=
-#INC=
-
-## For OSF/1 10.41
-#ARCH=
-#LIB=
-#OPT= -O -Olimit 700
-#CC= cc
-#DBG=
-#INC=
-
-## For Linux with gcc
-#ARCH=
-#LIB=
-#OPT= -O2
-#CC= gcc
-#DBG=
-#INC=
-
-VERSION= 1.4
-prefix= /usr/local/dist/DIR/nttcp-$(VERSION)
-#prefix= /usr/local
-#CFLAGS = $(ARCH) $(DBG) $(DEF) $(INC) $(OPT) -DVERSION=\"$(VERSION)\"
-CFLAGS = $(ARCH) $(CFLG) -DVERSION=\"$(VERSION)\"
-LFLAGS = $(DBG)
-
-nttcp: nttcp.o support.o
- $(CC) $(LFLAGS) nttcp.o -o nttcp support.o $(LIB)
-
-support.o: support.c support.h
-
-dist:
- if [ -d nttcp-$(VERSION) ]; then \
- rm -f nttcp-$(VERSION)/*; \
- else \
- mkdir nttcp-$(VERSION); \
- fi
- ln nttcp.c nttcp.1 support.c support.h \
- README Makefile nttcp-$(VERSION)
- tar cvf - nttcp-$(VERSION) | gzip > /tmp/nttcp-$(VERSION).tar.gz; \
- zip -lgr /tmp/nttcp`echo $(VERSION)|tr -d .`.zip nttcp-$(VERSION)
-
-install: nttcp
- -mkdir -p $(prefix)/bin
- -mkdir -p $(prefix)/man/man1
- cp nttcp $(prefix)/bin
- cp nttcp.1 $(prefix)/man/man1
-
-clean:
- rm -f *.o
-
-clobber: clean
- rm -rf core nttcp nttcp-$(VERSION)
diff --git a/benchmarks/nttcp/files/patch-aa b/benchmarks/nttcp/files/patch-aa
deleted file mode 100644
index 0f908806e9b6..000000000000
--- a/benchmarks/nttcp/files/patch-aa
+++ /dev/null
@@ -1,31 +0,0 @@
---- Makefile.old Wed Oct 7 15:12:25 1998
-+++ Makefile Mon Dec 7 23:03:15 1998
-@@ -109,12 +109,12 @@
- #INC=
-
- ## For FreeBSD
--#ARCH= -DFreeBSD
--#LIB=
--#OPT= -O2
--#CC= cc
--#DBG=
--#INC=
-+ARCH= -DFreeBSD
-+LIB=
-+OPT= -O2
-+CC= cc
-+DBG=
-+INC=
-
- ## For SGI IRIX 5.3, 6.2 (cc or gcc)
- #ARCH=
-@@ -151,7 +151,8 @@
- VERSION= 1.4
- prefix= /usr/local/dist/DIR/nttcp-$(VERSION)
- #prefix= /usr/local
--CFLAGS = $(ARCH) $(DBG) $(DEF) $(INC) $(OPT) -DVERSION=\"$(VERSION)\"
-+#CFLAGS = $(ARCH) $(DBG) $(DEF) $(INC) $(OPT) -DVERSION=\"$(VERSION)\"
-+CFLAGS = $(ARCH) $(CFLG) -DVERSION=\"$(VERSION)\"
- LFLAGS = $(DBG)
-
- nttcp: nttcp.o support.o
diff --git a/benchmarks/nttcp/pkg-comment b/benchmarks/nttcp/pkg-comment
deleted file mode 100644
index 24a2539e003c..000000000000
--- a/benchmarks/nttcp/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-A client/server program for testing network performance
diff --git a/benchmarks/nttcp/pkg-descr b/benchmarks/nttcp/pkg-descr
deleted file mode 100644
index 8f018711ffa3..000000000000
--- a/benchmarks/nttcp/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-This program is a much more convient version of the ttcp program.
-It uses inetd (or simulates its behaviour) to start off the remote
-side program which will send/receive data. Both sides measure the time
-and number of bytes transfered. The local side will print the measures.
-The format of the output can be specified on the commandline.
-
-Bill Fumerola <billf@chc-chimes.com>
diff --git a/benchmarks/nttcp/pkg-plist b/benchmarks/nttcp/pkg-plist
deleted file mode 100644
index e64420d1b349..000000000000
--- a/benchmarks/nttcp/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/nttcp