aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/pipebench/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/pipebench/Makefile')
-rw-r--r--benchmarks/pipebench/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/benchmarks/pipebench/Makefile b/benchmarks/pipebench/Makefile
index a982f0a31123..4a85a058bb13 100644
--- a/benchmarks/pipebench/Makefile
+++ b/benchmarks/pipebench/Makefile
@@ -7,19 +7,20 @@
#
PORTNAME= pipebench
-PORTVERSION= 0.20
+PORTVERSION= 0.40
CATEGORIES= benchmarks
MASTER_SITES= ftp://ftp.habets.pp.se/pub/synscan/
MAINTAINER= mich@freebsdcluster.org
COMMENT= Pipebench shows current throughput/amount of data through a pipe
-USE_REINPLACE= yes
+CFLAGS+= -w -pedantic
+USE_REINPLACE= yes
+
+do-build:
+ cd ${WRKSRC} && \
+ ${CC} ${CFLAGS} -o ${PORTNAME} ${PORTNAME}.c
-post-patch:
-post-patch:
- @${REINPLACE_CMD} -e "s|^CC|#CC|g" \
- -e "s|^CFLAGS|#CFLAGS|g" ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pipebench ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/pipebench.1 ${PREFIX}/man/man1