aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/polygraph31/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/polygraph31/Makefile')
-rw-r--r--benchmarks/polygraph31/Makefile34
1 files changed, 5 insertions, 29 deletions
diff --git a/benchmarks/polygraph31/Makefile b/benchmarks/polygraph31/Makefile
index adc20bc04449..b02812a4bbce 100644
--- a/benchmarks/polygraph31/Makefile
+++ b/benchmarks/polygraph31/Makefile
@@ -6,41 +6,17 @@
#
PORTNAME= polygraph
-PORTVERSION= 2.2.7
+PORTVERSION= 2.7.6
CATEGORIES= benchmarks www
-MASTER_SITES= http://polygraph.ircache.net/sources/tars/ \
- http://www.chg.ru/~dima/
+MASTER_SITES= http://www.web-polygraph.org/downloads/srcs/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+EXTRACT_SUFX= .tgz
MAINTAINER= demon@FreeBSD.org
-BROKEN= "Does not build"
-
-WRKSRC= ${WRKDIR}/polygraph
+IS_INTERACTIVE= yes
GNU_CONFIGURE= YES
-
-post-patch:
- @ ${MV} ${WRKSRC}/src/exprep.pl ${WRKSRC}/src/exprep.pl.pre_sed
- @ ${SED} -e 's#/usr/bin/perl#${PERL5}#' \
- ${WRKSRC}/src/exprep.pl.pre_sed > ${WRKSRC}/src/exprep.pl
- @ ${MV} ${WRKSRC}/tools/BB/bb.pl ${WRKSRC}/tools/BB/bb.pl.pre_sed
- @ ${SED} -e 's#/usr/bin/perl#${PERL5}#' \
- -e 's#/usr/people/bakeoff/BB#${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/polygraph#' \
- ${WRKSRC}/tools/BB/bb.pl.pre_sed> ${WRKSRC}/tools/BB/bb.pl
-
-do-install:
-
-.for file in polyclt polysrv lr lx distr_test pop_test rng_test aka piper polymon
- @ ${INSTALL_PROGRAM} ${WRKSRC}/src/$(file) ${PREFIX}/bin
-.endfor
- @ ${INSTALL_PROGRAM} ${WRKSRC}/src/udp2tcpd ${PREFIX}/sbin
- @ ${INSTALL_SCRIPT} ${WRKSRC}/src/exprep.pl ${PREFIX}/bin/exprep
- @ ${INSTALL_SCRIPT} ${WRKSRC}/tools/BB/bb.pl ${PREFIX}/bin
- @ ${MKDIR} ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/polygraph
-.for file in Blob.pm Executer.pm Tools.pm Command.pm Logger.pm
- @ ${INSTALL_SCRIPT} ${WRKSRC}/tools/BB/$(file) \
- ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/polygraph
-.endfor
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.include <bsd.port.mk>