aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/postal/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/postal/Makefile')
-rw-r--r--benchmarks/postal/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/benchmarks/postal/Makefile b/benchmarks/postal/Makefile
index 4ae4d857cea7..06b800c00ada 100644
--- a/benchmarks/postal/Makefile
+++ b/benchmarks/postal/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= postal
-PORTVERSION= 0.69
+PORTVERSION= 0.70
CATEGORIES= benchmarks mail
MASTER_SITES= http://www.coker.com.au/postal/
EXTRACT_SUFX= .tgz
@@ -15,6 +15,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= mm@FreeBSD.org
COMMENT= Benchmark SMTP/POP servers
+OPTIONS= SSL "Build with OpenSSL support" on
+
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -26,9 +28,14 @@ MAN8= bhm.8 postal.8 rabid.8
.include <bsd.port.pre.mk>
+CONFIGURE_ARGS= --disable-gnutls
+
+.if !defined(WITH_SSL)
+CONFIGURE_ARGS+= --disable-openssl
+.endif
+
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
-CONFIGURE_ARGS= --disable-gnutls
CONFIGURE_ENV+= CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
.include <bsd.port.post.mk>