aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/pybench/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/pybench/Makefile')
-rw-r--r--benchmarks/pybench/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/benchmarks/pybench/Makefile b/benchmarks/pybench/Makefile
index 706e8781a556..6e1064e46054 100644
--- a/benchmarks/pybench/Makefile
+++ b/benchmarks/pybench/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 2.0
CATEGORIES= benchmarks python
MASTER_SITES= http://downloads.egenix.com/python/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= scjamorim@bsd.com.br
COMMENT= An extensible benchmark suite for Python
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -18,6 +18,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_ZIP= yes
USE_PYTHON= yes
+PORTDOCS= README
+
do-build:
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
@${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
@@ -30,7 +32,9 @@ do-install:
> ${WRKDIR}/pybench.sh
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.for docs in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
+.endfor
.endif
@${INSTALL_SCRIPT} ${WRKDIR}/pybench.sh ${PREFIX}/bin/pybench