aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/siege/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/siege/Makefile')
-rw-r--r--benchmarks/siege/Makefile24
1 files changed, 17 insertions, 7 deletions
diff --git a/benchmarks/siege/Makefile b/benchmarks/siege/Makefile
index bdf4c49a68c8..a34e8e1b24ce 100644
--- a/benchmarks/siege/Makefile
+++ b/benchmarks/siege/Makefile
@@ -2,21 +2,31 @@
# $FreeBSD$
PORTNAME= siege
-PORTVERSION= 3.0.5
-CATEGORIES= benchmarks
-MASTER_SITES= http://www.joedog.org/pub/siege/
+PORTVERSION= 3.0.6
+CATEGORIES= benchmarks www
+MASTER_SITES= http://www.joedog.org/pub/siege/ \
+ http://fossies.org/linux/www/
MAINTAINER= ports@FreeBSD.org
COMMENT= HTTP regression testing and benchmarking utility
LICENSE= GPLv2
-GNU_CONFIGURE= yes
-USE_OPENSSL= yes
-
USES= perl5
-
+USE_OPENSSL= yes
+USE_AUTOTOOLS= libtoolize aclocal autoheader automake autoconf
+LIBTOOLIZE_ARGS=--copy --force
+AUTOMAKE_ARGS= --add-missing --copy
+CONFIGURE_ENV= PERL="${PERL}"
CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE} --disable-shared \
--sysconfdir=${ETCDIR}
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^\(AC_PROG_SHELL\)|dnl \1|' ${WRKSRC}/configure.ac
+
+pre-configure:
+ @${RM} -f ${WRKSRC}/acinclude.m4
+ @${RM} -f ${WRKSRC}/utils/missing
+
.include <bsd.port.mk>