aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/sipp/files/patch-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/sipp/files/patch-Makefile')
-rw-r--r--benchmarks/sipp/files/patch-Makefile83
1 files changed, 0 insertions, 83 deletions
diff --git a/benchmarks/sipp/files/patch-Makefile b/benchmarks/sipp/files/patch-Makefile
deleted file mode 100644
index 06c2bf30c561..000000000000
--- a/benchmarks/sipp/files/patch-Makefile
+++ /dev/null
@@ -1,83 +0,0 @@
---- Makefile.orig 2007-09-06 11:51:24.000000000 +0300
-+++ Makefile 2007-09-08 19:16:08.000000000 +0300
-@@ -18,8 +18,6 @@
- # From Hewlett Packard Company.
- #
-
---include local.mk
--
- # Output binary to be built
- OUTPUT=sipp
-
-@@ -69,7 +67,7 @@
- CC_SunOS=gcc
- CC_Cygwin=cc
- CC_Darwin=cc
--CC=$(CC_$(SYSTEM))
-+CC?=$(CC_$(SYSTEM))
-
- # C++ compiler mapping
- CPP_hpux=aCC
-@@ -79,7 +77,7 @@
- CPP_SunOS=g++
- CPP_Cygwin=g++
- CPP_Darwin=g++
--CPP=$(CPP_$(SYSTEM))
-+CPP?=$(CPP_$(SYSTEM))
-
- #Model specific flags
- MFLAGS_ia64=+DD64
-@@ -102,7 +100,7 @@
- CFLAGS_SunOS=-g -D__SUNOS
- CFLAGS_Cygwin=-D__CYGWIN -Dsocklen_t=int
- CFLAGS_Darwin=-D__DARWIN
--CFLAGS=$(CFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS) $(PCAPPLAY) $(EXTRACFLAGS)
-+CFLAGS+=$(CFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS) $(PCAPPLAY) $(EXTRACFLAGS)
-
- #C++ Compiler Flags
- CPPFLAGS_hpux=-AA -mt -D__HPUX +W829
-@@ -112,7 +110,7 @@
- CPPFLAGS_SunOS=-g -D__SUNOS
- CPPFLAGS_Cygwin=-D__CYGWIN -Dsocklen_t=int
- CPPFLAGS_Darwin=-D__DARWIN
--CPPFLAGS=$(CPPFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS) $(PCAPPLAY) $(EXTRACPPFLAGS)
-+CPPFLAGS+=$(CPPFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS) $(PCAPPLAY) $(EXTRACPPFLAGS)
-
- #Linker mapping
- CCLINK_hpux=aCC
-@@ -122,7 +120,7 @@
- CCLINK_SunOS=gcc
- CCLINK_Cygwin=g++
- CCLINK_Darwin=g++
--CCLINK=$(CCLINK_$(SYSTEM))
-+CCLINK?=$(CCLINK_$(SYSTEM))
-
- #Linker Flags
- LFLAGS_hpux=-AA -mt
-@@ -138,7 +136,7 @@
- LIBS_linux= -ldl -lpthread -lncurses -lstdc++ -lm -L /usr/local/lib -L /usr/lib -L /usr/lib64
- LIBS_hpux= -lcurses -lpthread -L /opt/openssl/lib -L /usr/local/lib
- LIBS_tru64= -lcurses -lpthread
--LIBS_freebsd= -lcurses -pthread
-+LIBS_freebsd= -lcurses -pthread -L /usr/local/lib
- LIBS_SunOS= -lcurses -lpthread -lnsl -lsocket -lstdc++ -lm -ldl -L /usr/local/ssl/lib/
- LIBS_Cygwin= -lcurses -lpthread -lstdc++ -L /usr/lib/WpdPack/Lib
- LIBS_Darwin= -lcurses
-@@ -146,7 +144,7 @@
-
- # Include directories
- INCDIR_linux=-I. -I/usr/include/openssl
--INCDIR_freebsd=-I. -I/opt/openssl/include
-+INCDIR_freebsd=-I. -I/usr/local/include
- INCDIR_hpux=-I. -I/usr/local/include -I/opt/openssl/include
- INCDIR_tru64=-I. -I/opt/openssl/include
- INCDIR_SunOS=-I. -I/usr/local/ssl/include/
-@@ -154,8 +152,6 @@
- INCDIR_Darwin=-I. -I/usr/local/ssl/include
- INCDIR=$(INCDIR_$(SYSTEM))
-
---include local.mk
--
- # Building without TLS and authentication (no openssl pre-requisite)
- all:
- make OSNAME=`uname|sed -e "s/CYGWIN.*/CYGWIN/"` MODELNAME=`uname -m|sed "s/Power Macintosh/ppc/"` $(OUTPUT)