aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/sysbench/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/sysbench/Makefile')
-rw-r--r--benchmarks/sysbench/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/benchmarks/sysbench/Makefile b/benchmarks/sysbench/Makefile
index ec2672a21f9b..01b6dec527a1 100644
--- a/benchmarks/sysbench/Makefile
+++ b/benchmarks/sysbench/Makefile
@@ -21,7 +21,9 @@ OPTIONS= MYSQL "Enable MySQL support" on \
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_MYSQL)
+.if defined(WITHOUT_MYSQL)
+CONFIGURE_ARGS+= --with-mysql=no
+.else
USE_MYSQL= yes
CONFIGURE_ARGS+= --with-mysql
.endif
@@ -30,6 +32,8 @@ CONFIGURE_ARGS+= --with-mysql
USE_PGSQL= yes
WANT_PGSQL_VER?= 80
CONFIGURE_ARGS+= --with-pgsql
+.else
+CONFIGURE_ARGS+= --with-pgsql=no
.endif
do-install: