aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/dkftpbench/Makefile2
-rw-r--r--benchmarks/himenobench/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/benchmarks/dkftpbench/Makefile b/benchmarks/dkftpbench/Makefile
index d21ebd5ef261..57782f91fb6e 100644
--- a/benchmarks/dkftpbench/Makefile
+++ b/benchmarks/dkftpbench/Makefile
@@ -16,7 +16,7 @@ COMMENT= A FTP benchmark program
PLIST_FILES= bin/dkftpbench
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_AUTOCONF_VER=259
USE_AUTOMAKE_VER=14
diff --git a/benchmarks/himenobench/Makefile b/benchmarks/himenobench/Makefile
index 318f907ab3f1..f105aa3f2371 100644
--- a/benchmarks/himenobench/Makefile
+++ b/benchmarks/himenobench/Makefile
@@ -29,7 +29,7 @@ RESTRICTED= "unsure to redistribute"
.if defined(WITH_OPTIMIZED_FLAGS)
FFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations
CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations
-.if (${ARCH} == "i386" && !${ARCH}== "amd64")
+.if (${MACHINE_ARCH} == "i386" && !${MACHINE_ARCH}== "amd64")
FFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3 -malign-double
CFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3 -malign-double
.endif # i386