aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/dhrystone/Makefile22
-rw-r--r--benchmarks/dhrystone/files/patch-Makefile12
-rw-r--r--benchmarks/dhrystone/pkg-descr6
3 files changed, 19 insertions, 21 deletions
diff --git a/benchmarks/dhrystone/Makefile b/benchmarks/dhrystone/Makefile
index 93e5618a0809..8a4b9d763a88 100644
--- a/benchmarks/dhrystone/Makefile
+++ b/benchmarks/dhrystone/Makefile
@@ -3,9 +3,9 @@
PORTNAME= dhrystone
PORTVERSION= 2.1
+PORTREVISION= 1
CATEGORIES= benchmarks
-MASTER_SITES= ${MASTER_SITE_NETLIB}
-MASTER_SITE_SUBDIR=benchmark
+MASTER_SITES= NETLIB/benchmark
DISTNAME= dhry-c
EXTRACT_SUFX=
@@ -14,30 +14,18 @@ COMMENT= Computing benchmark for integer operations
LICENSE= BSD2CLAUSE
-EXTRACT_CMD= ${MKDIR} ${WRKSRC};cd ${WRKSRC} && ${SH}
+EXTRACT_CMD= ${SH}
+NO_WRKSUBDIR= yes
PLIST_FILES= bin/dhry
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= RATIONALE submit.frm README_C VARIATIONS
-.endif
-
-do-build:
- cd ${WRKSRC} && ${CC} ${CFLAGS} -c dhry_1.c && \
- ${CC} ${CFLAGS} -c dhry_2.c && \
- ${CC} -o dhry *.o
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dhry ${STAGEDIR}${PREFIX}/bin
-.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
-.endfor
-.endif
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/benchmarks/dhrystone/files/patch-Makefile b/benchmarks/dhrystone/files/patch-Makefile
new file mode 100644
index 000000000000..25e0f93d5a71
--- /dev/null
+++ b/benchmarks/dhrystone/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- Makefile.orig 2015-01-16 10:40:03.233485586 +0000
++++ Makefile 2015-01-16 10:50:21.034404184 +0000
+@@ -0,0 +1,9 @@
++OBJ= dhry_1.o dhry_2.o
++
++all: dhry
++
++dhry: $(OBJ)
++ $(CC) $(LDFLAGS) $(OBJ) -o $@
++
++%.o: %.c
++ $(CC) -o $@ $< $(CFLAGS)
diff --git a/benchmarks/dhrystone/pkg-descr b/benchmarks/dhrystone/pkg-descr
index 7aa6f74758d6..35c8c091fdcb 100644
--- a/benchmarks/dhrystone/pkg-descr
+++ b/benchmarks/dhrystone/pkg-descr
@@ -1,12 +1,10 @@
-Dhrystone benchmark
-
Dhrystone is a synthetic computing benchmark program developed in 1984
by Reinhold P. Weicker intended to be representative of system (integer)
programming. The Dhrystone grew to become representative of general
processor (CPU) performance.
DMIPS value is result of dhrystone test divided by 1757, results are often
-reported in DMIPS/Mhz. For more information, see
-http://en.wikipedia.org/wiki/Dhrystone
+reported in DMIPS/MHz. For more information, see
+http://en.wikipedia.org/wiki/Dhrystone.
WWW: http://www.netlib.org/benchmark/