aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/bonnie/Makefile1
-rw-r--r--benchmarks/bonnie/pkg-plist1
-rw-r--r--benchmarks/forkbomb/Makefile1
-rw-r--r--benchmarks/forkbomb/pkg-plist1
-rw-r--r--benchmarks/iozone/Makefile1
-rw-r--r--benchmarks/iozone/pkg-plist1
-rw-r--r--benchmarks/nttcp/Makefile1
-rw-r--r--benchmarks/nttcp/pkg-plist1
-rw-r--r--benchmarks/pipebench/Makefile4
-rw-r--r--benchmarks/pipebench/pkg-plist1
-rw-r--r--benchmarks/rawio/Makefile1
-rw-r--r--benchmarks/rawio/pkg-plist1
-rw-r--r--benchmarks/scimark2c/Makefile1
-rw-r--r--benchmarks/scimark2c/pkg-plist1
-rw-r--r--benchmarks/stream/Makefile1
-rw-r--r--benchmarks/stream/pkg-plist1
-rw-r--r--benchmarks/ubench/Makefile1
-rw-r--r--benchmarks/ubench/pkg-plist1
-rw-r--r--benchmarks/webbench/Makefile2
-rw-r--r--benchmarks/webbench/pkg-plist1
20 files changed, 13 insertions, 11 deletions
diff --git a/benchmarks/bonnie/Makefile b/benchmarks/bonnie/Makefile
index 0dff57f6766c..fc48af66cd7e 100644
--- a/benchmarks/bonnie/Makefile
+++ b/benchmarks/bonnie/Makefile
@@ -20,6 +20,7 @@ NO_WRKSUBDIR= yes
MAKE_ARGS+= -e CFLAGS="${CFLAGS}"
ALL_TARGET= bsd
MAN1= bonnie.1
+PLIST_FILES= bin/bonnie
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/Bonnie ${PREFIX}/bin/bonnie
diff --git a/benchmarks/bonnie/pkg-plist b/benchmarks/bonnie/pkg-plist
deleted file mode 100644
index 2ed0c99e881a..000000000000
--- a/benchmarks/bonnie/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/bonnie
diff --git a/benchmarks/forkbomb/Makefile b/benchmarks/forkbomb/Makefile
index 5dff1c9133f2..82ba5de1d35f 100644
--- a/benchmarks/forkbomb/Makefile
+++ b/benchmarks/forkbomb/Makefile
@@ -20,5 +20,6 @@ MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
MAN8= forkbomb.8
+PLIST_FILES= sbin/forkbomb
.include <bsd.port.mk>
diff --git a/benchmarks/forkbomb/pkg-plist b/benchmarks/forkbomb/pkg-plist
deleted file mode 100644
index 7c3d45c645a8..000000000000
--- a/benchmarks/forkbomb/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-sbin/forkbomb
diff --git a/benchmarks/iozone/Makefile b/benchmarks/iozone/Makefile
index 7433f1a4aa09..cb1d947dd602 100644
--- a/benchmarks/iozone/Makefile
+++ b/benchmarks/iozone/Makefile
@@ -25,6 +25,7 @@ MAKE_ARGS= freebsd
ALL_TARGET=
MAN1= iozone.1
+PLIST_FILES= bin/iozone
do-install:
${STRIP_CMD} ${WRKSRC}/iozone
diff --git a/benchmarks/iozone/pkg-plist b/benchmarks/iozone/pkg-plist
deleted file mode 100644
index a263dd18c84e..000000000000
--- a/benchmarks/iozone/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/iozone
diff --git a/benchmarks/nttcp/Makefile b/benchmarks/nttcp/Makefile
index f5329b2cafd7..70717b1d6a8d 100644
--- a/benchmarks/nttcp/Makefile
+++ b/benchmarks/nttcp/Makefile
@@ -18,6 +18,7 @@ COMMENT= A client/server program for testing network performance
ALL_TARGET= nttcp
MAN1= nttcp.1
+PLIST_FILES= bin/nttcp
USE_GMAKE= yes
MAKE_ENV+= OPT="${CFLAGS}"
diff --git a/benchmarks/nttcp/pkg-plist b/benchmarks/nttcp/pkg-plist
deleted file mode 100644
index e64420d1b349..000000000000
--- a/benchmarks/nttcp/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/nttcp
diff --git a/benchmarks/pipebench/Makefile b/benchmarks/pipebench/Makefile
index 595f2867d8d1..99fa3d1322e3 100644
--- a/benchmarks/pipebench/Makefile
+++ b/benchmarks/pipebench/Makefile
@@ -24,5 +24,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pipebench ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/pipebench.1 ${PREFIX}/man/man1
-MAN1= pipebench.1
+MAN1= pipebench.1
+PLIST_FILES= bin/pipebench
+
.include <bsd.port.mk>
diff --git a/benchmarks/pipebench/pkg-plist b/benchmarks/pipebench/pkg-plist
deleted file mode 100644
index 5140f6dec434..000000000000
--- a/benchmarks/pipebench/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/pipebench
diff --git a/benchmarks/rawio/Makefile b/benchmarks/rawio/Makefile
index 240326e89709..d6ab812f7c07 100644
--- a/benchmarks/rawio/Makefile
+++ b/benchmarks/rawio/Makefile
@@ -17,6 +17,7 @@ COMMENT= Test performance of low-level storage devices
NO_WRKSUBDIR= yes
MAN1= rawio.1
+PLIST_FILES= bin/rawio
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rawio ${PREFIX}/bin
diff --git a/benchmarks/rawio/pkg-plist b/benchmarks/rawio/pkg-plist
deleted file mode 100644
index b3ec41224d34..000000000000
--- a/benchmarks/rawio/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/rawio
diff --git a/benchmarks/scimark2c/Makefile b/benchmarks/scimark2c/Makefile
index d24651f764f5..9d96856f8681 100644
--- a/benchmarks/scimark2c/Makefile
+++ b/benchmarks/scimark2c/Makefile
@@ -14,6 +14,7 @@ DISTNAME= ${PORTNAME}
MAINTAINER= thierry@pompo.net
COMMENT= An ANSI C version of the SciMark2 benchmark
+PLIST_FILES= bin/scimark2
WRKSRC= ${WRKDIR}
USE_REINPLACE= yes
USE_ZIP= yes
diff --git a/benchmarks/scimark2c/pkg-plist b/benchmarks/scimark2c/pkg-plist
deleted file mode 100644
index 97c242e9934c..000000000000
--- a/benchmarks/scimark2c/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/scimark2
diff --git a/benchmarks/stream/Makefile b/benchmarks/stream/Makefile
index f0fb83679959..830955fe5945 100644
--- a/benchmarks/stream/Makefile
+++ b/benchmarks/stream/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= sf@slappy.org
COMMENT= Synthetic benchmark program that measures sustainable memory bandwidth
MAKEFILE= ${FILESDIR}/Makefile
+PLIST_FILES= bin/stream
do-extract:
@${MKDIR} ${WRKDIR}
diff --git a/benchmarks/stream/pkg-plist b/benchmarks/stream/pkg-plist
deleted file mode 100644
index a5bd75c67d6b..000000000000
--- a/benchmarks/stream/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/stream
diff --git a/benchmarks/ubench/Makefile b/benchmarks/ubench/Makefile
index a4c0e4a2b21f..b4aadc848866 100644
--- a/benchmarks/ubench/Makefile
+++ b/benchmarks/ubench/Makefile
@@ -17,5 +17,6 @@ COMMENT= Unix Benchmark Utility for CPU(s) and memory
HAS_CONFIGURE= yes
MAN8= ubench.8
+PLIST_FILES= bin/ubench
.include <bsd.port.mk>
diff --git a/benchmarks/ubench/pkg-plist b/benchmarks/ubench/pkg-plist
deleted file mode 100644
index 06feb3e79c9d..000000000000
--- a/benchmarks/ubench/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/ubench
diff --git a/benchmarks/webbench/Makefile b/benchmarks/webbench/Makefile
index d3efcc13c8e9..d3b29953effa 100644
--- a/benchmarks/webbench/Makefile
+++ b/benchmarks/webbench/Makefile
@@ -27,6 +27,8 @@ MAN1= webbench.1
PORTDOCS= copyright changelog
.endif
+PLIST_FILES= bin/webbench
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/webbench ${PREFIX}/bin
.if !defined(NO_INSTALL_MANPAGES)
diff --git a/benchmarks/webbench/pkg-plist b/benchmarks/webbench/pkg-plist
deleted file mode 100644
index ce6434a852b2..000000000000
--- a/benchmarks/webbench/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/webbench