aboutsummaryrefslogtreecommitdiff
path: root/biology/emboss/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/emboss/Makefile')
-rw-r--r--biology/emboss/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/biology/emboss/Makefile b/biology/emboss/Makefile
new file mode 100644
index 000000000000..cc038a5ff719
--- /dev/null
+++ b/biology/emboss/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: emboss
+# Date created: 31 July 2000
+# Whom: Johann Visagie <johann@egenetics.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= emboss
+PORTVERSION= 1.0.0
+CATEGORIES= biology
+MASTER_SITES= ftp://ftp.uk.embnet.org/pub/EMBOSS/
+DISTNAME= EMBOSS-${PORTVERSION}
+
+MAINTAINER= johann@egenetics.com
+
+LIB_DEPENDS= gd.1:${PORTSDIR}/graphics/gd \
+ png.4:${PORTSDIR}/graphics/png
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/gd" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>