aboutsummaryrefslogtreecommitdiff
path: root/biology/emboss/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/emboss/Makefile')
-rw-r--r--biology/emboss/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/biology/emboss/Makefile b/biology/emboss/Makefile
index cc038a5ff719..2279b54b1d9b 100644
--- a/biology/emboss/Makefile
+++ b/biology/emboss/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= emboss
-PORTVERSION= 1.0.0
+PORTVERSION= 1.1.0
CATEGORIES= biology
MASTER_SITES= ftp://ftp.uk.embnet.org/pub/EMBOSS/
DISTNAME= EMBOSS-${PORTVERSION}
@@ -23,4 +23,20 @@ USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/gd" \
LIBS="-L${LOCALBASE}/lib"
+post-install:
+ @ ${INSTALL_DATA} ${WRKSRC}/emboss/acd/emboss.default \
+ ${PREFIX}/etc/emboss.default.sample
+.if !defined(BATCH)
+ @ ${CAT} ${PKGMESSAGE}
+.endif
+
+DOC_DIRS= doc/manuals doc/tutorials doc/programs/text doc/programs/html
+
+post-patch:
+.for DIR in ${DOC_DIRS}
+ @perl -pi.orig -e \
+ "s#share/\\$$\(PACKAGE\)/doc#share/doc/\\$$\(PACKAGE\)#" \
+ ${WRKSRC}/${DIR}/Makefile.in
+.endfor
+
.include <bsd.port.mk>