aboutsummaryrefslogtreecommitdiff
path: root/biology/gperiodic/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/gperiodic/Makefile')
-rw-r--r--biology/gperiodic/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/biology/gperiodic/Makefile b/biology/gperiodic/Makefile
index 2a9540aec05a..a31d1f6c424d 100644
--- a/biology/gperiodic/Makefile
+++ b/biology/gperiodic/Makefile
@@ -6,28 +6,31 @@
#
PORTNAME= gperiodic
-PORTVERSION= 1.2.2
+PORTVERSION= 1.2.6
CATEGORIES= biology
MASTER_SITES= ftp://ftp.seul.org/pub/gperiodic/
MAINTAINER= ports@FreeBSD.org
-WRKSRC= ${WRKDIR}/gperiodic
+WRKSRC= ${WRKDIR}/${PORTNAME}
USE_X_PREFIX= yes
-USE_GMAKE= yes
USE_GTK= yes
+USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
MAN1= gperiodic.1
+post-extract:
+ @${RM} -f ${WRKSRC}/config.cache
+
post-install:
- ${INSTALL_MAN} ${WRKSRC}/man/gperiodic.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/man/gperiodic.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/gperiodic
-.for file in AUTHORS COPYING Changes README
+.for file in AUTHORS Changes README
${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/gperiodic
.endfor
.endif