aboutsummaryrefslogtreecommitdiff
path: root/biology/jalview/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/jalview/Makefile')
-rw-r--r--biology/jalview/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/biology/jalview/Makefile b/biology/jalview/Makefile
new file mode 100644
index 000000000000..9596bb7d00e5
--- /dev/null
+++ b/biology/jalview/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: jalview
+# Date created: 11 Jan 2006
+# Whom: Fernan Aguero <fernan@iib.unsam.edu.ar>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jalview
+PORTVERSION= 2.07
+CATEGORIES= biology java
+MASTER_SITES= http://www.jalview.org/source/
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/}
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= A viewer and editor for multiple sequence alignments
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+USE_ANT= yes
+ALL_TARGET= makejars
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+SUB_FILES= jalview.sh
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/jalview.sh ${PREFIX}/bin/jalview
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/dist/* ${DATADIR}
+
+.include <bsd.port.mk>