aboutsummaryrefslogtreecommitdiff
path: root/biology/nab/files
diff options
context:
space:
mode:
Diffstat (limited to 'biology/nab/files')
-rw-r--r--biology/nab/files/config.h74
-rw-r--r--biology/nab/files/patch-Makefile70
-rw-r--r--biology/nab/files/patch-configure11
-rw-r--r--biology/nab/files/patch-reslib:conf.lib14
-rw-r--r--biology/nab/files/patch-src:wc_helix.nab11
-rw-r--r--biology/nab/files/patch-src_Makefile17
-rw-r--r--biology/nab/files/patch-src_cgen.c21
-rw-r--r--biology/nab/files/patch-src_nabgrm.y20
-rw-r--r--biology/nab/files/patch-suppose_Makefile10
-rw-r--r--biology/nab/files/pkg-message.in8
10 files changed, 0 insertions, 256 deletions
diff --git a/biology/nab/files/config.h b/biology/nab/files/config.h
deleted file mode 100644
index a3e4889166b3..000000000000
--- a/biology/nab/files/config.h
+++ /dev/null
@@ -1,74 +0,0 @@
-# NAB configuration file, created with: ./configure -p4 -static gcc
-
-###############################################################################
-
-# (1) You need to define the symbol NABHOME in your environment
-
-# NABHOME should be an absolute path to the top-level NAB directory;
-# files are installed to the following directories:
-
-BINDIR=$(NABHOME)/bin
-LIBDIR=$(NABHOME)/lib
-INCDIR=$(NABHOME)/include
-
-###############################################################################
-
-
-# (2) If you want to search additional libraries by default, add them
-# to the FLIBS variable here. (External libraries can also be linked into
-# NAB programs simply by including them on the command line; libraries
-# included in FLIBS are always searched.)
-
-FLIBS= $(LIBDIR)/libsym.a $(LIBDIR)/lapack.a $(LIBDIR)/blas.a $(LIBDIR)/f2c.a -static
-
-###############################################################################
-
-# (3) Modify any of the following if you need to change, e.g. to use gcc
-# rather than cc, etc.
-
-SHELL=/bin/sh
-
-# Set the C compiler, etc.
-
-# For GNU: CC-->gcc; LEX-->flex; YACC-->bison -y -t;
-# Note: If your lexer is "really" flex, you need to set
-# LEX=flex below. For example, on many linux distributions,
-# /usr/bin/lex is really just a pointer to /usr/bin/flex,
-# so LEX=flex is necessary. In general, gcc seems to need
-# flex.
-
-NABFLAGS=
-
-LEX= flex
-YACC= yacc
-AR= ar
-RANLIB= ranlib
-
-# Set the C-preprocessor. Code for a small preprocessor is in
-# uccp-1.3; it gets installed as $(NABHOME)/bin/ucpp;
-# this can generally be used (maybe not on 64-bit machines like altix).
-
-CPP= /usr/local/bin/ucpp -l
-
-# If you are going to link in Fortran routines, you need
-# to set the compiler information here. (Also, add the appropriate entries
-# to the FLIBS variable, above.)
-#
-#FC=f77
-#FFLAGS?=$(FFLAGS)
-#FOPTFLAGS?=$(FFLAGS)
-FREEFORMAT_FLAG=-ffree-form
-
-# These variables control whether we will use compiled versions of BLAS
-# and LAPACK (which are generally slower), or whether those libraries are
-# already available (presumably in an optimized form).
-
-LAPACK=install
-BLAS=install
-F2C=install
-UCPP=
-
-# For Windows/cygwin, set SFX to ".exe"; for Unix/Linux leave it empty:
-
-SFX=
-
diff --git a/biology/nab/files/patch-Makefile b/biology/nab/files/patch-Makefile
deleted file mode 100644
index 3fe19a6cd21f..000000000000
--- a/biology/nab/files/patch-Makefile
+++ /dev/null
@@ -1,70 +0,0 @@
---- Makefile.orig Mon Aug 21 11:16:05 2006
-+++ Makefile Fri Dec 15 16:06:57 2006
-@@ -2,31 +2,32 @@
-
- include config.h
-
-+all: install
-+
- install:
- -mkdir $(BINDIR) $(LIBDIR) $(INCDIR)
-- (cd ucpp-1.3; make $(UCPP) )
-- (cd byacc; make install )
--
--# here are the Fortran versions:
--# (cd lapack; make $(LAPACK) )
--# (cd blas; make $(BLAS) )
--
--# here are the C versions:
-- (cd clapack; make $(LAPACK) )
-- (cd cblas; make $(BLAS) )
-- (cd f2c; make $(F2C) )
--
-- (cd cifparse; make install )
-- (cd src; make install )
-- (cd nss; make install )
-- (cd tleap; make install )
-+ (cd clapack; env NABHOME=.. make $(LAPACK) )
-+ (cd cblas; env NABHOME=.. make $(BLAS) )
-+ (cd f2c; env NABHOME=.. make $(F2C) )
-+ (cd cifparse; env NABHOME=.. make install )
-+ (cd src; env NABHOME=.. make install )
-+ (cd nss; env NABHOME=.. make install )
-+ (cd tleap; env NABHOME=.. make install )
-+# (cd peptide && \
-+# env NABHOME=.. ../bin/nab $(CFLAGS) -o peptide peptide.nab )
-+# cp -p peptide/README doc/README-peptide
-+# mv peptide/peptide bin
-+# @echo
-+# @echo "Ignore conflicting types warnings"
-+# @echo
-+# (cd suppose; env NABHOME=.. make all )
-+# cp -p suppose/suppose.1 doc
-+# mv suppose/suppose suppose/PCA_suppose bin
- @echo
-- @echo "completed installation of NAB version 5"
-+ @echo "completed installation of NAB version 5.1"
- @echo
-
- clean:
-- (cd ucpp-1.3; make clean )
-- (cd byacc; make clean )
- (cd cifparse; make clean )
- (cd src; make clean )
- (cd nss; make clean )
-@@ -34,10 +35,12 @@
- (cd cblas; make clean )
- (cd clapack; make clean )
- (cd f2c; make clean )
--
-+ (cd suppose; make clean )
-+ (cd peptide && rm -f peptide.c peptide )
-+
- # note: "make test" needs to follow "make", since it is very hard to
- # tell if the compiler is completely "made" or not.
-
- test::
-- (cd test; make test)
-- (cd nss; make test)
-+ (cd test; env NABHOME=.. make test)
-+ (cd nss; env NABHOME=.. make test)
diff --git a/biology/nab/files/patch-configure b/biology/nab/files/patch-configure
deleted file mode 100644
index 412974c8fcfa..000000000000
--- a/biology/nab/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Mon Aug 21 11:18:10 2006
-+++ configure Fri Aug 25 22:30:10 2006
-@@ -61,7 +61,7 @@
- p4='no'
- gotolib='no'
- compiler='gcc'
--processor=`/bin/uname -p`
-+processor=`/usr/bin/uname -p`
- static='no'
-
- while [ $# -gt 0 ]; do
diff --git a/biology/nab/files/patch-reslib:conf.lib b/biology/nab/files/patch-reslib:conf.lib
deleted file mode 100644
index 088afbf29321..000000000000
--- a/biology/nab/files/patch-reslib:conf.lib
+++ /dev/null
@@ -1,14 +0,0 @@
-*** reslib/conf.lib.orig Wed Mar 10 19:00:11 1999
---- reslib/conf.lib Tue Dec 23 15:34:07 2003
-***************
-*** 13,18 ****
---- 13,21 ----
- PI 1 pi helix
- phi -57.0 psi -70.0 omega 180.0
-
-+ PPII 1 polyproline II helix
-+ phi -75.0 psi 145.0 omega 180.0
-+
- EXTENDED 1 extended conformation
- phi 180.0 psi 180.0 omega 180.0
-
diff --git a/biology/nab/files/patch-src:wc_helix.nab b/biology/nab/files/patch-src:wc_helix.nab
deleted file mode 100644
index 960c76b2341e..000000000000
--- a/biology/nab/files/patch-src:wc_helix.nab
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/wc_helix.nab.orig Thu Apr 7 20:17:27 2005
-+++ src/wc_helix.nab Fri Sep 15 09:22:13 2006
-@@ -25,6 +25,8 @@
-
- loup["g"] = "G"; loup["a"] = "A";
- loup["t"] = "T"; loup["c"] = "C";
-+ loup["G"] = "G"; loup["A"] = "A";
-+ loup["T"] = "T"; loup["C"] = "C";
-
- has_s = 1; has_a = 1;
- if( sreslib == "" ) sreslib_use = "all_nucleic94.lib";
diff --git a/biology/nab/files/patch-src_Makefile b/biology/nab/files/patch-src_Makefile
deleted file mode 100644
index 70f7c1b799f1..000000000000
--- a/biology/nab/files/patch-src_Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/Makefile.orig Fri Aug 11 17:38:10 2006
-+++ src/Makefile Fri Dec 15 17:01:39 2006
-@@ -189,6 +189,14 @@
- cp defreal.h $(INCDIR)
- cp nab.h $(INCDIR)
-
-+beforerealinstall:
-+ $(CC) -DBINDIR='"$(PREFIX)/bin"' \
-+ -DINCDIR='"$(PREFIX)/include"' \
-+ -DLIBDIR='"$(PREFIX)/share/nab/lib"' \
-+ $(CFLAGS) -DCC='"$(CC)"' -DCPP='"$(CPP)"' \
-+ -DFLIBS='"$(PREFIX)/share/nab/lib/libsym.a $(PREFIX)/share/nab/lib/lapack.a $(PREFIX)/share/nab/lib/blas.a $(PREFIX)/share/nab/lib/f2c.a"' \
-+ -static -o ../bin/nab${SFX} nab.c
-+
- uninstall: clean
- -rm -f \
- $(BINDIR)/nab2c$(SFX) $(BINDIR)/nab$(SFX) $(INCDIR)/nabcode.h \
diff --git a/biology/nab/files/patch-src_cgen.c b/biology/nab/files/patch-src_cgen.c
deleted file mode 100644
index c6538200406e..000000000000
--- a/biology/nab/files/patch-src_cgen.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/cgen.c.orig Thu Apr 7 20:17:27 2005
-+++ src/cgen.c Sun Apr 17 20:21:22 2005
-@@ -102,6 +102,7 @@
- void CG_genpids( NODE_T * );
- void CG_genpdecl( NODE_T * );
- char *CG_gentemp( int );
-+void CG_gennull( void );
-
- static int getdims( NODE_T *, int, int, int *, NODE_T *[] );
- static NODE_T *mk_arraysize( int, NODE_T *[], int );
-@@ -115,6 +116,10 @@
- static void CG_debug( char [], NODE_T *, int );
-
- FILE *tmpfile();
-+
-+void CG_gennull( )
-+{
-+}
-
- int CG_init( char cfname[], int aopt )
- {
diff --git a/biology/nab/files/patch-src_nabgrm.y b/biology/nab/files/patch-src_nabgrm.y
deleted file mode 100644
index 348e3a157d8b..000000000000
--- a/biology/nab/files/patch-src_nabgrm.y
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/nabgrm.y.orig Thu Apr 7 20:17:27 2005
-+++ src/nabgrm.y Sun Apr 17 20:21:36 2005
-@@ -41,6 +41,8 @@
-
- # define YYSTYPE_IS_DECLARED 1
-
-+#define YYSTYPE_IS_DECLARED 1
-+
- %}
-
- %token <ival> SYM_ADDRESS
-@@ -299,7 +301,7 @@
- f_stmtpart SYM_RBRACE
- { CG_genestmts( TRUE );
- CG_genop( NULL, SYM_RBRACE ); }
-- SYM_SEMICOLON ;
-+ SYM_SEMICOLON { CG_gennull ( ); } ;
- f_defpart : lv_decls
- | { $$ = NULL; } ;
- lv_decls : var_decl
diff --git a/biology/nab/files/patch-suppose_Makefile b/biology/nab/files/patch-suppose_Makefile
deleted file mode 100644
index 9317b951a30c..000000000000
--- a/biology/nab/files/patch-suppose_Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
---- suppose/Makefile.orig Thu Apr 7 20:18:34 2005
-+++ suppose/Makefile Sat Aug 26 08:49:50 2006
-@@ -1,5 +1,7 @@
- include ../config.h
-
-+all: suppose$(SFX) PCA_suppose$(SFX)
-+
- suppose$(SFX): suppose.nab
- nab -o suppose$(SFX) suppose.nab
-
diff --git a/biology/nab/files/pkg-message.in b/biology/nab/files/pkg-message.in
deleted file mode 100644
index e89f4516b02e..000000000000
--- a/biology/nab/files/pkg-message.in
+++ /dev/null
@@ -1,8 +0,0 @@
--------------------------------------------------------------------------------
-You must set the environment variable NABHOME to
-
- %%DATADIR%%
-
-before nab is used. This is needed so that nab can find its residue and
-structure databases.
--------------------------------------------------------------------------------