aboutsummaryrefslogtreecommitdiff
path: root/biology/ncbi-toolkit/files
diff options
context:
space:
mode:
Diffstat (limited to 'biology/ncbi-toolkit/files')
-rw-r--r--biology/ncbi-toolkit/files/freebsd.ncbi.mk31
-rw-r--r--biology/ncbi-toolkit/files/patch-aa8
-rw-r--r--biology/ncbi-toolkit/files/patch-ab19
-rw-r--r--biology/ncbi-toolkit/files/patch-ac11
-rw-r--r--biology/ncbi-toolkit/files/patch-ncbilcl.fbd18
5 files changed, 22 insertions, 65 deletions
diff --git a/biology/ncbi-toolkit/files/freebsd.ncbi.mk b/biology/ncbi-toolkit/files/freebsd.ncbi.mk
deleted file mode 100644
index ccbb2bf8f60f..000000000000
--- a/biology/ncbi-toolkit/files/freebsd.ncbi.mk
+++ /dev/null
@@ -1,31 +0,0 @@
-#
-# $Id$ freebsd.ncbi.mk
-#
-# That platform is not supported and is contributed to NCBI by
-# freebsd-bio@freebsd.net
-#
-NCBI_DEFAULT_LCL = bsd
-NCBI_MAKE_SHELL = /bin/sh
-NCBI_CC = cc
-NCBI_CFLAGS1 = ${CFLAGS} -c
-NCBI_LDFLAGS1 = -O
-NCBI_OPTFLAG =
-NCBI_BIN_MASTER = /home/coremake/ncbi/bin
-NCBI_BIN_COPY = /home/coremake/ncbi/bin
-NCBI_INCDIR = /home/coremake/ncbi/include
-NCBI_LIBDIR = /home/coremake/ncbi/lib
-NCBI_ALTLIB = /home/coremake/ncbi/altlib
-#will work only when you have Motif installed!
-NCBI_VIBFLAG = -I/usr/X11R6/include -L/usr/X11R6/lib -DWIN_MOTIF
-NCBI_VIBLIBS = -lXm -lXmu -lXp -lXpm -lXt -lX11 -lXext
-NCBI_DISTVIBLIBS = -L/usr/X11R6/lib /usr/X11R6/lib/libXm.a /usr/X11R6/lib/libXp.a /usr/X11R6/lib/libXpm.a -lXmu -lXt -lX11 -lXext
-NCBI_OTHERLIBS = -lm
-NCBI_RANLIB = ranlib
-# Used by makedis.csh
-NCBI_MT_OTHERLIBS =
-NCBI_THREAD_OBJ = ncbithr.o
-NETENTREZVERSION = 2.02c2ASN1SPEC6
-
-NCBI_LBSM_SRC = ncbi_service_lbsmd_stub.c
-NCBI_LBSM_OBJ = ncbi_service_lbsmd_stub.o
-
diff --git a/biology/ncbi-toolkit/files/patch-aa b/biology/ncbi-toolkit/files/patch-aa
index e2e8abb9e5a7..8bb479ec9b0b 100644
--- a/biology/ncbi-toolkit/files/patch-aa
+++ b/biology/ncbi-toolkit/files/patch-aa
@@ -6,11 +6,11 @@
$(SRC2) $(SRC1) $(OTHERLIBS) -lsocket -lnsl
+
+EXE= Nentrez Psequin \
-+ asn2ff asn2xml asndhuff asntool \
-+ bl2seq blast.REAL blastall blastcl3 blastclust blastpgp \
++ asn2ff asn2gb asn2xml asndhuff asntool \
++ blastall blastcl3 blastclust blastpgp \
+ cdscan checksub copymat \
-+ ddv dosimple \
-+ entrcmd errhdr fa2htgs fastacmd findspl fmerge formatdb \
++ ddv demo_regexp demo_regexp_grep dosimple \
++ entrcmd entrez2 errhdr fa2htgs fastacmd findspl fmerge formatdb \
+ getfeat getmesh getpub getseq gil2bin \
+ idfetch impala indexpub \
+ makemat makeset megablast \
diff --git a/biology/ncbi-toolkit/files/patch-ab b/biology/ncbi-toolkit/files/patch-ab
deleted file mode 100644
index 886047ae18c8..000000000000
--- a/biology/ncbi-toolkit/files/patch-ab
+++ /dev/null
@@ -1,19 +0,0 @@
---- corelib/ncbilcl.bsd.orig Mon Apr 3 08:50:57 2000
-+++ corelib/ncbilcl.bsd Mon Apr 3 08:51:55 2000
-@@ -74,7 +74,6 @@
- #include <stdio.h>
- #include <ctype.h>
- #include <string.h>
--#include <malloc.h>
- #include <memory.h>
- #include <stdlib.h>
- #include <math.h>
-@@ -84,7 +83,7 @@
-
- /* Check if there are POSIX threads available */
- #ifdef _POSIX_THREADS
--#define POSIX_THREADS_AVAIL
-+#define POSIX_THREADS_AVAIL_broken
- #endif
-
-
diff --git a/biology/ncbi-toolkit/files/patch-ac b/biology/ncbi-toolkit/files/patch-ac
deleted file mode 100644
index 3099d88124c9..000000000000
--- a/biology/ncbi-toolkit/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- corelib/ncbienv.c.orig Tue Jan 25 08:16:49 2000
-+++ corelib/ncbienv.c Mon Apr 3 08:56:02 2000
-@@ -183,6 +183,8 @@
-
- #ifdef OS_UNIX
- #include <pwd.h>
-+#include <sys/param.h>
-+#define LOGNAME_MAX MAXLOGNAME
- #endif /* OS_UNIX */
- #ifdef OS_MAC
- #include <Gestalt.h>
diff --git a/biology/ncbi-toolkit/files/patch-ncbilcl.fbd b/biology/ncbi-toolkit/files/patch-ncbilcl.fbd
new file mode 100644
index 000000000000..75dae534e758
--- /dev/null
+++ b/biology/ncbi-toolkit/files/patch-ncbilcl.fbd
@@ -0,0 +1,18 @@
+--- corelib/ncbilcl.fbd.orig Sat Nov 23 07:05:04 2002
++++ corelib/ncbilcl.fbd Sat May 3 10:06:18 2003
+@@ -67,6 +67,7 @@
+ /*----------------------------------------------------------------------*/
+ #define SYSV_IPC_AVAIL /* System V Interprocess Communication available */
+ #define _POSIX_C_SOURCE 199309L
++#define _XOPEN_SOURCE 600 /* req. for 5.0 */
+ #define HAVE_STRCASECMP 1
+ #define HAVE_STRDUP 1
+
+@@ -87,6 +88,7 @@
+ #include <errno.h>
+ #include <float.h>
+ #include <unistd.h>
++#include <sys/select.h> /* req. for 5.0. fd_set def. moved from types.h */
+
+ /* Check if there are POSIX threads available */
+ #ifdef _POSIX_THREADS