aboutsummaryrefslogtreecommitdiff
path: root/biology/p5-Bio-Phylo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/p5-Bio-Phylo/Makefile')
-rw-r--r--biology/p5-Bio-Phylo/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/biology/p5-Bio-Phylo/Makefile b/biology/p5-Bio-Phylo/Makefile
index edd4ea96ac55..32e882e5d35e 100644
--- a/biology/p5-Bio-Phylo/Makefile
+++ b/biology/p5-Bio-Phylo/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Bio-Phylo
-PORTVERSION= 0.07
+PORTVERSION= 0.12
CATEGORIES= biology perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Bio
@@ -18,12 +18,12 @@ COMMENT= Phylogenetic analysis using perl
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Math/Random.pm:${PORTSDIR}/math/p5-Math-Random \
${SITE_PERL}/SVG.pm:${PORTSDIR}/textproc/p5-SVG \
${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
- ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ ${SITE_PERL}/IO/String.pm:${PORTSDIR}/devel/p5-IO-String \
+ ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple
RUN_DEPENDS= ${BUILD_DEPENDS}
MAN3= Bio::Phylo.3 \
- Bio::Phylo::CONSTANT.3 \
- Bio::Phylo::Exceptions.3 \
Bio::Phylo::Forest.3 \
Bio::Phylo::Forest::Node.3 \
Bio::Phylo::Forest::Tree.3 \
@@ -36,6 +36,8 @@ MAN3= Bio::Phylo.3 \
Bio::Phylo::Matrices::Datum.3 \
Bio::Phylo::Matrices::Matrix.3 \
Bio::Phylo::Matrices::Sequence.3 \
+ Bio::Phylo::Parsers::Fastnewick.3 \
+ Bio::Phylo::Parsers::Fastnexus.3 \
Bio::Phylo::Parsers::Newick.3 \
Bio::Phylo::Parsers::Nexus.3 \
Bio::Phylo::Parsers::Table.3 \
@@ -43,9 +45,14 @@ MAN3= Bio::Phylo.3 \
Bio::Phylo::Taxa.3 \
Bio::Phylo::Taxa::Taxon.3 \
Bio::Phylo::Treedrawer.3 \
- Bio::Phylo::Treedrawer::SVG.3 \
+ Bio::Phylo::Treedrawer::Svg.3 \
+ Bio::Phylo::Unparsers::Mrp.3 \
Bio::Phylo::Unparsers::Newick.3 \
- Bio::Phylo::Unparsers::Pagel.3
+ Bio::Phylo::Unparsers::Nexus.3 \
+ Bio::Phylo::Unparsers::Pagel.3 \
+ Bio::Phylo::Util::CONSTANT.3 \
+ Bio::Phylo::Util::Exceptions.3 \
+ Bio::Phylo::Util::IDPool.3
PERL_CONFIGURE= yes