aboutsummaryrefslogtreecommitdiff
path: root/biology/psi88/files
diff options
context:
space:
mode:
Diffstat (limited to 'biology/psi88/files')
-rw-r--r--biology/psi88/files/Makefile.top9
-rw-r--r--biology/psi88/files/patch-aa116
-rw-r--r--biology/psi88/files/patch-ba19
-rw-r--r--biology/psi88/files/patch-bb143
4 files changed, 287 insertions, 0 deletions
diff --git a/biology/psi88/files/Makefile.top b/biology/psi88/files/Makefile.top
new file mode 100644
index 000000000000..8b1ab0338d92
--- /dev/null
+++ b/biology/psi88/files/Makefile.top
@@ -0,0 +1,9 @@
+all:
+ (cd src/ && make all)
+
+install:
+ (cd src/ && make install)
+
+clean:
+ (cd src/ && make clean)
+
diff --git a/biology/psi88/files/patch-aa b/biology/psi88/files/patch-aa
new file mode 100644
index 000000000000..0dbcb2dfa792
--- /dev/null
+++ b/biology/psi88/files/patch-aa
@@ -0,0 +1,116 @@
+*** src/Makefile.orig Sat May 25 04:04:15 1991
+--- src/Makefile Thu Nov 12 11:20:18 1998
+***************
+*** 27,37 ****
+ # level and when it is working, increase the optimization level. So far
+ # optimization has never caused problems with this program.
+ #
+! # SGI 4D series flags
+ #
+ f77 = f77
+! FFLAGS = -w0 -O4 -G 64
+! LFLAGS = -lfastm -lfpe -s
+ #
+ # SUN Sparc series flags version 1.3 or later compiler
+ #
+--- 27,43 ----
+ # level and when it is working, increase the optimization level. So far
+ # optimization has never caused problems with this program.
+ #
+! # FreeBSD
+ #
+ f77 = f77
+! FFLAGS = -O3 -Wall
+! LFLAGS =
+! #
+! # SGI 4D series flags
+! #
+! #f77 = f77
+! #FFLAGS = -w0 -O4 -G 64
+! #LFLAGS = -lfastm -lfpe -s
+ #
+ # SUN Sparc series flags version 1.3 or later compiler
+ #
+***************
+*** 60,66 ****
+ # Place your G88/G90 util library definition here if you wish to
+ # compile chk2psi
+ #
+! G90LIB = /usr/people/frisch/g90/libg90.a
+ #
+ # define the directory where the executables will reside
+ # usually /usr/local/bin or ~/bin to put it in your own directory
+--- 66,72 ----
+ # Place your G88/G90 util library definition here if you wish to
+ # compile chk2psi
+ #
+! #G90LIB = /usr/people/frisch/g90/libg90.a
+ #
+ # define the directory where the executables will reside
+ # usually /usr/local/bin or ~/bin to put it in your own directory
+***************
+*** 84,96 ****
+ #######################################################################
+ #
+
+! all: PSI1 PSICON PSI2CT PSI2HP PSI2PS PREPLOT chk2psi $(EXTRAS)
+
+ #
+ # Install in the executable directory - may need to be superuser
+ # depending on where you decide to put it (/usr/local/bin for instance)
+ #
+! install: PSI1 PSICON PSI2CT PSI2HP PSI2PS PREPLOT chk2psi $(EXTRAS)
+ mv PSI1 $(BIN)
+ chmod +rx $(BIN)/PSI1
+ mv PSICON $(BIN)
+--- 90,104 ----
+ #######################################################################
+ #
+
+! # all: PSI1 PSICON PSI2CT PSI2HP PSI2PS PREPLOT chk2psi $(EXTRAS)
+! all: PSI1 PSICON PSI2CT PSI2HP PSI2PS PREPLOT $(EXTRAS)
+
+ #
+ # Install in the executable directory - may need to be superuser
+ # depending on where you decide to put it (/usr/local/bin for instance)
+ #
+! #install: PSI1 PSICON PSI2CT PSI2HP PSI2PS PREPLOT chk2psi $(EXTRAS)
+! install: PSI1 PSICON PSI2CT PSI2HP PSI2PS PREPLOT $(EXTRAS)
+ mv PSI1 $(BIN)
+ chmod +rx $(BIN)/PSI1
+ mv PSICON $(BIN)
+***************
+*** 99,106 ****
+ chmod +rx $(BIN)/PREPLOT
+ mv PSI2* $(BIN)
+ chmod +rx $(BIN)/PSI2*
+! mv chk2psi $(BIN)
+! chmod +rx $(BIN)/chk2psi
+
+ #
+ # This is the Density matrix generation program (PSI1/88)
+--- 107,115 ----
+ chmod +rx $(BIN)/PREPLOT
+ mv PSI2* $(BIN)
+ chmod +rx $(BIN)/PSI2*
+!
+! # mv chk2psi $(BIN)
+! # chmod +rx $(BIN)/chk2psi
+
+ #
+ # This is the Density matrix generation program (PSI1/88)
+***************
+*** 164,169 ****
+ # Clean up when done
+ #
+ clean :
+! touch a.out foo.o core foo.u foo.f17 foo.22
+ rm -f a.out *.o core *.u *.f17 *.f2*
+
+--- 173,178 ----
+ # Clean up when done
+ #
+ clean :
+! touch a.out foo.o core foo.u foo.f17 foo.22
+ rm -f a.out *.o core *.u *.f17 *.f2*
+
diff --git a/biology/psi88/files/patch-ba b/biology/psi88/files/patch-ba
new file mode 100644
index 000000000000..494065d08251
--- /dev/null
+++ b/biology/psi88/files/patch-ba
@@ -0,0 +1,19 @@
+*** unix/rpsi1.orig Sat May 25 03:50:02 1991
+--- unix/rpsi1 Thu Nov 12 11:25:41 1998
+***************
+*** 10,16 ****
+ #
+ # Run PSI1/88 using cmdlin.psi1 as input
+ #
+! time ./PSI1 < $1.psi1
+ #
+ # remove any old files with the target name
+ #
+--- 10,16 ----
+ #
+ # Run PSI1/88 using cmdlin.psi1 as input
+ #
+! time PSI1 < $1.psi1
+ #
+ # remove any old files with the target name
+ #
diff --git a/biology/psi88/files/patch-bb b/biology/psi88/files/patch-bb
new file mode 100644
index 000000000000..7ffeacd6497f
--- /dev/null
+++ b/biology/psi88/files/patch-bb
@@ -0,0 +1,143 @@
+*** unix/rpsi2.orig Sat May 25 03:50:02 1991
+--- unix/rpsi2 Thu Nov 12 23:41:19 1998
+***************
+*** 13,79 ****
+ if ($1 == '-hp') goto noargs
+ if ($1 == '-ct') goto noargs
+ echo -n 'no [-ps][-pk][-hp][-ct] options - attempting to run PSI2 '
+! /bin/time PSI2 < $1.psi2
+ else
+ if ($argv[1] == '-hp') then
+ echo "Generating contours ... please wait."
+! /bin/time PSI2HP < $2.psi2
+ echo -n "Renaming HP Plotter file to "$2".hpp"
+! mv -f fort.10 $2.hpp
+ echo "Done"
+ else if ($argv[2] == '-hp') then
+ echo "Generating contours ... please wait."
+! /bin/time PSI2HP < $1.psi2
+ echo -n "Renaming HP Plotter file to "$1".hpp"
+! mv -f fort.10 $1.hpp
+ echo "Done"
+ else if ($argv[1] == '-ct') then
+ echo "Generating contours ... please wait."
+! /bin/time PSI2CT < $2.psi2
+ echo -n "Plotting for ChemText ... "
+ echo -n "Renaming ChemText Metafile to "$2".met"
+! mv -f fort.10 $2.met
+ echo "Done"
+ else if ($argv[2] == '-ct') then
+ echo "Generating contours ... please wait."
+! /bin/time PSI2CT < $1.psi2
+ echo -n "Renaming ChemText Metafile to "$1".met"
+ mv -f fort.10 $1.met
+ echo "Done"
+ else if ($argv[1] == '-pk') then
+ echo "Generating contours ... please wait."
+ # setenv OUTPUT_DEVICE PostScript
+! /bin/time PSI2PS < $2.psi2
+ echo -n "Renaming PostScript file to "$2".ps"
+ mv -f psplot $argv[2].ps
+ echo "Done"
+ else if ($argv[2] == '-pk') then
+ echo "Generating contours ... please wait."
+ # setenv OUTPUT_DEVICE PostScript
+! /bin/time PSI2PS < $1.psi2
+ echo -n "Renaming PostScript file to "$1".ps"
+ mv -f psplot $argv[1].ps
+ echo "Done"
+ else if ($argv[1] == '-ps') then
+ echo "Generating contours ... please wait."
+ setenv OUTPUT_DEVICE PostScript
+! /bin/time PSI2 < $2.psi2
+ #SYSV echo -n "Plotting on the LaserWriter ... ";lp -c /tmp/ps_plot$USER
+ #SYSV rm -f /tmp/ps_plot$USER
+! #BSD echo -n "Plotting on the LaserWriter ... ";lpr -r /tmp/ps_plot$USER
+
+! echo ' edit command file to choose print options, then remove this line'
+
+ echo "Done"
+ else if ($argv[2] == '-ps') then
+ echo "Generating contours ... please wait."
+ setenv OUTPUT_DEVICE PostScript
+! /bin/time PSI2 < $1.psi2
+ #SYSV echo -n "Plotting on the LaserWriter ... ";lp -c /tmp/ps_plot$USER
+ #SYSV rm -f /tmp/ps_plot$USER
+! #BSD echo -n "Plotting on the LaserWriter ... ";lpr -r /tmp/ps_plot$USER
+
+! echo ' edit command file to choose print options, then remove this line'
+
+ echo "Done"
+ else
+--- 13,83 ----
+ if ($1 == '-hp') goto noargs
+ if ($1 == '-ct') goto noargs
+ echo -n 'no [-ps][-pk][-hp][-ct] options - attempting to run PSI2 '
+! time PSI2 < $1.psi2
+! # PSI2 is linked to PSI2PS, then output file `psplot' will moved to $argv[1].ps
+! echo ': PSI2 is PSI2PS, now'
+! mv -f psplot $argv[1].ps
+! echo "Done"
+ else
+ if ($argv[1] == '-hp') then
+ echo "Generating contours ... please wait."
+! time PSI2HP < $2.psi2
+ echo -n "Renaming HP Plotter file to "$2".hpp"
+! mv -f fort.66 $2.hpp
+ echo "Done"
+ else if ($argv[2] == '-hp') then
+ echo "Generating contours ... please wait."
+! time PSI2HP < $1.psi2
+ echo -n "Renaming HP Plotter file to "$1".hpp"
+! mv -f fort.66 $1.hpp
+ echo "Done"
+ else if ($argv[1] == '-ct') then
+ echo "Generating contours ... please wait."
+! time PSI2CT < $2.psi2
+ echo -n "Plotting for ChemText ... "
+ echo -n "Renaming ChemText Metafile to "$2".met"
+! mv -f fort.66 $2.met
+ echo "Done"
+ else if ($argv[2] == '-ct') then
+ echo "Generating contours ... please wait."
+! time PSI2CT < $1.psi2
+ echo -n "Renaming ChemText Metafile to "$1".met"
+ mv -f fort.10 $1.met
+ echo "Done"
+ else if ($argv[1] == '-pk') then
+ echo "Generating contours ... please wait."
+ # setenv OUTPUT_DEVICE PostScript
+! time PSI2PS < $2.psi2
+ echo -n "Renaming PostScript file to "$2".ps"
+ mv -f psplot $argv[2].ps
+ echo "Done"
+ else if ($argv[2] == '-pk') then
+ echo "Generating contours ... please wait."
+ # setenv OUTPUT_DEVICE PostScript
+! time PSI2PS < $1.psi2
+ echo -n "Renaming PostScript file to "$1".ps"
+ mv -f psplot $argv[1].ps
+ echo "Done"
+ else if ($argv[1] == '-ps') then
+ echo "Generating contours ... please wait."
+ setenv OUTPUT_DEVICE PostScript
+! time PSI2 < $2.psi2
+ #SYSV echo -n "Plotting on the LaserWriter ... ";lp -c /tmp/ps_plot$USER
+ #SYSV rm -f /tmp/ps_plot$USER
+! echo -n "Plotting on the LaserWriter ... ";lpr -r /tmp/ps_plot$USER
+
+! #echo ' edit command file to choose print options, then remove this line'
+
+ echo "Done"
+ else if ($argv[2] == '-ps') then
+ echo "Generating contours ... please wait."
+ setenv OUTPUT_DEVICE PostScript
+! time PSI2 < $1.psi2
+ #SYSV echo -n "Plotting on the LaserWriter ... ";lp -c /tmp/ps_plot$USER
+ #SYSV rm -f /tmp/ps_plot$USER
+! echo -n "Plotting on the LaserWriter ... ";lpr -r /tmp/ps_plot$USER
+
+! #echo ' edit command file to choose print options, then remove this line'
+
+ echo "Done"
+ else