aboutsummaryrefslogtreecommitdiff
path: root/biology/pycogent/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/pycogent/Makefile')
-rw-r--r--biology/pycogent/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/biology/pycogent/Makefile b/biology/pycogent/Makefile
new file mode 100644
index 000000000000..4b8348554b0d
--- /dev/null
+++ b/biology/pycogent/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: pycogent
+# Date created: 20 June, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pycogent
+PORTVERSION= 1.3.1
+CATEGORIES= biology python
+MASTER_SITES= SF
+DISTNAME= PyCogent-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A toolkit for statistical analysis of biological sequences
+
+BUILD_DEPENDS= ${PYNUMPY} \
+ ${LOCALBASE}/bin/cython:${PORTSDIR}/lang/cython \
+ ${LOCALBASE}/bin/sphinx-build:${PORTSDIR}/textproc/py-sphinx \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy>=0.5:${PORTSDIR}/databases/py-sqlalchemy
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= cogent
+
+.include <bsd.port.mk>