aboutsummaryrefslogtreecommitdiff
path: root/biology/pycogent/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/pycogent/Makefile')
-rw-r--r--biology/pycogent/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/biology/pycogent/Makefile b/biology/pycogent/Makefile
index 1dd650abc285..f0725592332c 100644
--- a/biology/pycogent/Makefile
+++ b/biology/pycogent/Makefile
@@ -2,14 +2,10 @@
# $FreeBSD$
PORTNAME= pycogent
-PORTVERSION= 1.5.3
-PORTREVISION= 3
+PORTVERSION= 1.9
CATEGORIES= biology python
-MASTER_SITES= SF/${PORTNAME}/PyCogent/${PORTVERSION}
-DISTNAME= PyCogent-${PORTVERSION}
-EXTRACT_SUFX= .tgz
-MAINTAINER= wen@FreeBSD.org
+MAINTAINER= python@FreeBSD.org
COMMENT= Toolkit for statistical analysis of biological sequences
LICENSE= GPLv2
@@ -17,10 +13,11 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${PYNUMPY} \
${LOCALBASE}/bin/cython:lang/cython \
${LOCALBASE}/bin/sphinx-build:textproc/py-sphinx \
- ${PYTHON_PKGNAMEPREFIX}sqlalchemy06>=0.5:databases/py-sqlalchemy06
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>=1.0.13:databases/py-sqlalchemy10
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= python
+USES= python:-2.7
+USE_GITHUB= yes
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>