aboutsummaryrefslogtreecommitdiff
path: root/biology/ruby-bio/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/ruby-bio/Makefile')
-rw-r--r--biology/ruby-bio/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/biology/ruby-bio/Makefile b/biology/ruby-bio/Makefile
new file mode 100644
index 000000000000..b21101ad859f
--- /dev/null
+++ b/biology/ruby-bio/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: BioRuby
+# Date created: 24 October 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bio
+PORTVERSION= 0.3.20011024
+CATEGORIES= biology ruby
+MASTER_SITES= ftp://ftp.bioruby.org/bioruby/src/
+MASTER_SITE_SUBDIR= knu
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}ruby-${PORTVERSION:R}-${PORTVERSION:E}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+
+RUBY_SHEBANG_FILES= ${WRKSRC}/bin/dbget
+
+do-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/sample/ ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/README ${RUBY_DOCDIR}/${PORTNAME}/
+.endif
+
+.include <bsd.port.mk>