aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
Diffstat (limited to 'biology')
-rw-r--r--biology/avida/Makefile8
-rw-r--r--biology/treeviewx/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/biology/avida/Makefile b/biology/avida/Makefile
index a4576c8c5991..00228e6d8d4e 100644
--- a/biology/avida/Makefile
+++ b/biology/avida/Makefile
@@ -13,6 +13,12 @@ MASTER_SITES= http://dllab.caltech.edu/avida/versions/
MAINTAINER= karlj000@unbc.ca
COMMENT= Avida is an auto-adaptive genetic system designed for ALife research
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/\.[[:alnum:]]+$//}
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -37,4 +43,4 @@ post-patch:
| ${SED} -e 's#%%PORTNAME%%#${PORTNAME}#g' \
> ${WRKSRC}/source/support/genesis.heads
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/biology/treeviewx/Makefile b/biology/treeviewx/Makefile
index 95d363f0dcea..7068b639492e 100644
--- a/biology/treeviewx/Makefile
+++ b/biology/treeviewx/Makefile
@@ -14,9 +14,15 @@ DISTNAME= tv-${PORTVERSION}
MAINTAINER= tonym@biolateral.com.au
COMMENT= A phylogenetic tree viewer
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
LIB_DEPENDS= wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk-devel
USE_GMAKE= yes
GNU_CONFIGURE= yes
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>