aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/tRNAscan-SE/Makefile28
-rw-r--r--biology/tRNAscan-SE/distinfo1
-rw-r--r--biology/tRNAscan-SE/files/patch-aa35
-rw-r--r--biology/tRNAscan-SE/pkg-comment1
-rw-r--r--biology/tRNAscan-SE/pkg-descr10
-rw-r--r--biology/tRNAscan-SE/pkg-plist26
7 files changed, 102 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index ead96e624098..1de3d9e94a34 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -44,6 +44,7 @@
SUBDIR += seaview
SUBDIR += seqio
SUBDIR += sim4
+ SUBDIR += tRNAscan-SE
SUBDIR += t_coffee
SUBDIR += tinker
SUBDIR += treeviewx
diff --git a/biology/tRNAscan-SE/Makefile b/biology/tRNAscan-SE/Makefile
new file mode 100644
index 000000000000..f175f5f1a357
--- /dev/null
+++ b/biology/tRNAscan-SE/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: tRNAscan-SE
+# Date created: 15 Jan 2002
+# Whom: chuynh@biolateral.com.au
+#
+# $FreeBSD$
+#
+
+PORTNAME= tRNAscan-SE
+PORTVERSION= 1.21
+CATEGORIES= biology
+MASTER_SITES= ftp://ftp.genetics.wustl.edu/pub/eddy/software/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= chuynh@biolateral.com.au
+
+MAN1= tRNAscan-SE.1
+
+#
+# have to install before testing as path to data files is hardcoded
+#
+post-install:
+ @ cd ${WRKSRC} && $(MAKE) testrun
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Manual.ps ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/biology/tRNAscan-SE/distinfo b/biology/tRNAscan-SE/distinfo
new file mode 100644
index 000000000000..d9f0e767d7c4
--- /dev/null
+++ b/biology/tRNAscan-SE/distinfo
@@ -0,0 +1 @@
+MD5 (tRNAscan-SE-1.21.tar.Z) = 8bdb481fbfc46836bf28f637eb96d306
diff --git a/biology/tRNAscan-SE/files/patch-aa b/biology/tRNAscan-SE/files/patch-aa
new file mode 100644
index 000000000000..82f9a3b420a0
--- /dev/null
+++ b/biology/tRNAscan-SE/files/patch-aa
@@ -0,0 +1,35 @@
+--- Makefile.orig Sat Oct 7 00:16:41 2000
++++ Makefile Thu Dec 20 17:26:37 2001
+@@ -19,10 +19,11 @@
+ ## (this could be 'perl5' or otherwise on some systems)
+ PERLBIN = perl
+
++prefix = ${PREFIX}
+ ## where you want things installed
+-BINDIR = $(HOME)/bin
+-LIBDIR = $(HOME)/lib/tRNAscan-SE
+-MANDIR = $(HOME)/man
++BINDIR = $(prefix)/bin
++LIBDIR = $(prefix)/share/tRNAscan-SE
++MANDIR = $(prefix)/man
+
+ ## NOTE !! If you later manually move the location of
+ ## binaries or data files in the BINDIR or LIBDIR directories,
+@@ -106,7 +107,7 @@
+
+ MPOBJ = mpviterbi.o mp-dbviterbi.o
+
+-all: $(PROGS) tRNAscanSE setpaths
++all: $(PROGS) tRNAscanSE
+
+ covels-SE: $(OBJ) scan_main.o
+ $(CC) $(CFLAGS) $(RFLAGS) -o covels-SE scan_main.o $(OBJ) $(LIBS)
+@@ -178,7 +179,7 @@
+ @echo ""
+ @rm -f testrun.out
+ @echo "tRNAscan-SE -d -y -o testrun.out Demo/F22B7.fa"
+- @if tRNAscan-SE -d -y -o testrun.out Demo/F22B7.fa; \
++ @if ./tRNAscan-SE -d -y -o testrun.out Demo/F22B7.fa; \
+ then echo ""; \
+ else echo "tRNAscan-SE did NOT complete properly."; fi
+ @if diff testrun.out testrun.ref; \
diff --git a/biology/tRNAscan-SE/pkg-comment b/biology/tRNAscan-SE/pkg-comment
new file mode 100644
index 000000000000..92cdd3eff0e5
--- /dev/null
+++ b/biology/tRNAscan-SE/pkg-comment
@@ -0,0 +1 @@
+An improved tool for transfer RNA detection
diff --git a/biology/tRNAscan-SE/pkg-descr b/biology/tRNAscan-SE/pkg-descr
new file mode 100644
index 000000000000..008e02d08a16
--- /dev/null
+++ b/biology/tRNAscan-SE/pkg-descr
@@ -0,0 +1,10 @@
+tRNAscan-SE was written in the PERL (version 5.0) script language.
+Input consists of DNA or RNA sequences in FASTA format. tRNA
+predictions are output in standard tabular or ACeDB format.
+tRNAscan-SE does no tRNA detection itself, but instead combines the
+strengths of three independent tRNA prediction programs by negotiating
+the flow of information between them, performing a limited amount of
+post-processing, and outputting the results in one of several
+formats.
+
+WWW: http://www.genetics.wustl.edu/eddy/software/
diff --git a/biology/tRNAscan-SE/pkg-plist b/biology/tRNAscan-SE/pkg-plist
new file mode 100644
index 000000000000..06992dc3d94b
--- /dev/null
+++ b/biology/tRNAscan-SE/pkg-plist
@@ -0,0 +1,26 @@
+bin/tRNAscan-SE
+bin/eufindtRNA
+bin/coves-SE
+bin/covels-SE
+bin/trnascan-1.4
+share/tRNAscan-SE/TPCsignal
+share/tRNAscan-SE/gcode.vertmito
+share/tRNAscan-SE/gcode.othmito
+share/tRNAscan-SE/gcode.invmito
+share/tRNAscan-SE/gcode.echdmito
+share/tRNAscan-SE/gcode.cilnuc
+share/tRNAscan-SE/TRNA2ns.cm
+share/tRNAscan-SE/TRNA2.cm
+share/tRNAscan-SE/TRNA2-eukns.cm
+share/tRNAscan-SE/TRNA2-euk.cm
+share/tRNAscan-SE/TRNA2-bactns.cm
+share/tRNAscan-SE/TRNA2-bact.cm
+share/tRNAscan-SE/TRNA2-archns.cm
+share/tRNAscan-SE/TRNA2-arch.cm
+share/tRNAscan-SE/PSELC.cm
+share/tRNAscan-SE/ESELC.cm
+share/tRNAscan-SE/Dsignal
+share/tRNAscan-SE/gcode.ystmito
+@dirrm share/tRNAscan-SE
+%%PORTDOCS%%share/doc/tRNAscan-SE/Manual.ps
+%%PORTDOCS%%@dirrm share/doc/tRNAscan-SE