aboutsummaryrefslogtreecommitdiff
path: root/cad/alliance/files
diff options
context:
space:
mode:
Diffstat (limited to 'cad/alliance/files')
-rw-r--r--cad/alliance/files/patch-06-fix-format-strings95
-rw-r--r--cad/alliance/files/patch-11-fix-segfaults115
-rw-r--r--cad/alliance/files/patch-all_src_XMX_motif.c60
-rw-r--r--cad/alliance/files/patch-asimut_src_Makefile.in22
-rw-r--r--cad/alliance/files/patch-distrib-etc-Makefile.am10
-rw-r--r--cad/alliance/files/patch-elp_src_elp.c44
-rw-r--r--cad/alliance/files/patch-exp__src__ht.c7
-rw-r--r--cad/alliance/files/patch-ppt_src_Makefile.in11
-rw-r--r--cad/alliance/files/patch-sea__src__sea.sh19
-rw-r--r--cad/alliance/files/patch-sea__src__seplace.sh17
-rw-r--r--cad/alliance/files/patch-sea__src__seroute.sh17
-rw-r--r--cad/alliance/files/patch-xgra-src-XSB_parse.c10
12 files changed, 287 insertions, 140 deletions
diff --git a/cad/alliance/files/patch-06-fix-format-strings b/cad/alliance/files/patch-06-fix-format-strings
new file mode 100644
index 000000000000..8b5faa79a1f0
--- /dev/null
+++ b/cad/alliance/files/patch-06-fix-format-strings
@@ -0,0 +1,95 @@
+Description: Format string fixes
+ This patch fixes some format string problems with fprintf().
+Author: Roland Stigge <stigge@antcom.de>
+
+===================================================================
+--- alliance-5.0-20110203.orig/rtd/src/rtd_drive.c 2002-09-30 18:21:10.000000000 +0200
++++ rtd/src/rtd_drive.c 2012-03-24 15:24:00.000000000 +0100
+@@ -100,7 +100,7 @@
+ RtlExprLength = Length;
+ }
+
+- fprintf( RtlFile, Name );
++ fprintf( RtlFile, "%s", Name );
+ }
+
+ /*------------------------------------------------------------\
+===================================================================
+--- alliance-5.0-20110203.orig/vpd/src/vpd_drive.c 2002-09-30 18:21:32.000000000 +0200
++++ vpd/src/vpd_drive.c 2012-03-24 15:37:53.000000000 +0100
+@@ -100,7 +100,7 @@
+ VpnExprLength = Length;
+ }
+
+- fprintf( VpnFile, Name );
++ fprintf( VpnFile, "%s", Name );
+ }
+
+ /*------------------------------------------------------------\
+===================================================================
+--- alliance-5.0-20110203.orig/boog/src/bog_normalize_message.c 2002-09-30 18:19:58.000000000 +0200
++++ boog/src/bog_normalize_message.c 2012-03-24 15:50:03.000000000 +0100
+@@ -106,7 +106,7 @@
+ }
+
+ fprintf(stderr,"BEH: ");
+- fprintf(stderr,message);
++ fprintf(stderr,"%s",message);
+ fprintf(stderr," in '");
+ fflush(stderr);
+ display_abl(abl);
+===================================================================
+--- alliance-5.0-20110203.orig/l2p/src/drive_ps.c 2005-02-17 16:34:44.000000000 +0100
++++ l2p/src/drive_ps.c 2012-03-24 16:02:33.000000000 +0100
+@@ -83,22 +83,22 @@
+ break;
+ case E_OPEN :
+ fprintf (stderr, "Problem while opening file ");
+- fprintf (stderr, msg);
++ fprintf (stderr, "%s", msg);
+ break;
+ case E_CLOSE :
+ fprintf (stderr, "Problem while closing file ");
+- fprintf (stderr, msg);
++ fprintf (stderr, "%s", msg);
+ break;
+ case E_WRITE :
+ fprintf (stderr, "Problem while writing file ");
+- fprintf (stderr, msg);
++ fprintf (stderr, "%s", msg);
+ break;
+ case E_READ :
+ fprintf (stderr, "Problem while reading file ");
+- fprintf (stderr, msg);
++ fprintf (stderr, "%s", msg);
+ break;
+ case E_OUTBOX :
+- fprintf (stderr, msg);
++ fprintf (stderr, "%s", msg);
+ break;
+ default :
+ fprintf (stderr, "Unknow internal error");
+===================================================================
+--- alliance-5.0-20110203.orig/loon/src/lon_normalize_message.c 2004-09-06 23:26:09.000000000 +0200
++++ loon/src/lon_normalize_message.c 2012-03-24 16:15:39.000000000 +0100
+@@ -106,7 +106,7 @@
+ }
+
+ fprintf(stderr,"BEH: ");
+- fprintf(stderr,message);
++ fprintf(stderr,"%s",message);
+ fprintf(stderr," in '");
+ fflush(stderr);
+ display_abl(abl);
+===================================================================
+--- alliance-5.0-20110203.orig/sea/src/util_LEFDEF.c 2004-09-29 23:40:46.000000000 +0200
++++ sea/src/util_LEFDEF.c 2012-03-24 16:36:27.000000000 +0100
+@@ -213,7 +213,7 @@
+ *pI = (char)0; pI += 1;
+ sprintf (asLEF, "%s(%s)", sTmp, pI);
+ } else {
+- sprintf (asLEF, sTmp);
++ sprintf (asLEF, "%s", sTmp);
+ }
+
+ return (asLEF);
diff --git a/cad/alliance/files/patch-11-fix-segfaults b/cad/alliance/files/patch-11-fix-segfaults
new file mode 100644
index 000000000000..cc7b6fa72457
--- /dev/null
+++ b/cad/alliance/files/patch-11-fix-segfaults
@@ -0,0 +1,115 @@
+Description: Fix segfaults in different executables
+ Some executables in the package crashed upon certain command line option
+ combinations. This patch fixes this.
+Author: Roland Stigge <stigge@antcom.de>
+Bug-Debian: http://bugs.debian.org/715651
+Bug-Debian: http://bugs.debian.org/716217
+Bug-Debian: http://bugs.debian.org/716529
+
+--- alliance-5.0-20120515.orig/asimut/src/vh_simulad.c
++++ asimut/src/vh_simulad.c
+@@ -155,8 +155,8 @@ char **argv;
+ arg_flg [i ] = 1;
+ }
+
+- if ((!strcmp (argv [i], "-fixeddelay"))
+- || (!strcmp (argv [i], "-fd")))
++ if (((!strcmp (argv [i], "-fixeddelay"))
++ || (!strcmp (argv [i], "-fd"))) && (argc > i + 1))
+ {
+ fixdly_flg = 1;
+ delay_mode |= BEH_DELAY_FIXED;
+@@ -165,8 +165,8 @@ char **argv;
+ arg_flg [i+1] = 1;
+ }
+
+- if ((!strcmp (argv [i], "-backdelay"))
+- || (!strcmp (argv [i], "-bd")))
++ if (((!strcmp (argv [i], "-backdelay"))
++ || (!strcmp (argv [i], "-bd"))) && (argc > i + 1))
+ {
+ bckdly_flg = i + 2;
+ delay_mode |= BEH_DELAY_BACKANOTATED;
+@@ -221,14 +221,14 @@ char **argv;
+ arg_flg [i] = 1;
+ }
+
+- if (!strcmp (argv [i], "-p"))
++ if (!strcmp (argv [i], "-p") && (argc > i + 1))
+ {
+ sscanf (argv [i+1], "%u", &max_pat);
+ arg_flg [i ] = 1;
+ arg_flg [i+1] = 1;
+ }
+
+- if (!strcmp (argv [i], "-l"))
++ if (!strcmp (argv [i], "-l") && (argc > i + 1))
+ {
+ sscanf (argv [i+1], "%u", &labelsiz);
+ arg_flg [i ] = 1;
+@@ -241,7 +241,7 @@ char **argv;
+ arg_flg [i] = 1;
+ }
+
+- if (!strcmp (argv [i], "-stat"))
++ if (!strcmp (argv [i], "-stat") && (argc > i + 1))
+ {
+ stat_flg = i + 2;
+ sscanf (argv [i+1], "%u", &ref_date);
+@@ -264,7 +264,7 @@ char **argv;
+ arg_flg [i+1] = 1;
+ }
+
+- if (!strcmp (argv [i], "-inspect"))
++ if (!strcmp (argv [i], "-inspect") && (argc > i + 1))
+ {
+ str = namealloc (argv [i+1]);
+ pt_pains = pat_addpains (pt_pains, str, str);
+--- alliance-5.0-20120515.orig/m2e/src/m2e.c
++++ m2e/src/m2e.c
+@@ -102,6 +102,8 @@ int ParseCommand(int argc,char *argv[])
+ switch(argv[i][1])
+ {
+ case 'v':
++ if (argc <= i + 1)
++ break;
+ i++;
+ sscanf(argv[i],"%d",&VerboseMode);
+ if(VerboseMode>=VMINFO)
+@@ -109,6 +111,8 @@ int ParseCommand(int argc,char *argv[])
+ break;
+
+ case 'o':
++ if (argc <= i + 1)
++ break;
+ i++;
+ OutputName=argv[i];
+ if(VerboseMode>=VMINFO)
+--- alliance-5.0-20120515.orig/mips_asm/src/mips_y.y
++++ mips_asm/src/mips_y.y
+@@ -92,14 +92,14 @@ char *argv [];
+ {
+ if (arg_flg [i] == 0)
+ {
+- if (!strcmp (argv[i], "-textsize"))
++ if (!strcmp (argv[i], "-textsize") && argc > i + 1)
+ {
+ sscanf (argv[i+1], "%u", &txt_siz);
+ arg_flg [i ] = 1;
+ arg_flg [i+1] = 1;
+ }
+
+- if (!strcmp (argv[i], "-datasize"))
++ if (!strcmp (argv[i], "-datasize") && argc > i + 1)
+ {
+ sscanf (argv[i+1], "%u", &dat_siz);
+ arg_flg [i ] = 1;
+@@ -112,7 +112,7 @@ char *argv [];
+ arg_flg [i] = 1 ;
+ }
+
+- if (!strcmp (argv[i], "-symbol"))
++ if (!strcmp (argv[i], "-symbol") && argc > i + 1)
+ {
+ MPS_SYMBOL = 'y' ;
+ symbol_fil = argv [i+1];
diff --git a/cad/alliance/files/patch-all_src_XMX_motif.c b/cad/alliance/files/patch-all_src_XMX_motif.c
deleted file mode 100644
index f791d1dbd830..000000000000
--- a/cad/alliance/files/patch-all_src_XMX_motif.c
+++ /dev/null
@@ -1,60 +0,0 @@
---- dreal/src/GMX_motif.c.orig Mon Sep 30 13:20:09 2002
-+++ dreal/src/GMX_motif.c Thu May 26 15:04:30 2005
-@@ -92,7 +92,6 @@
-
- {
- "*.DrealMainWindow.iconName : Dreal",
-- "*DrealMenuBar*fontList : -*-helvetica-bold-r-*--14-*",
- "*foreground : black",
- "*background : gray",
- "*fontList : -*-helvetica-medium-r-*--12-*",
---- graal/src/GMX_motif.c.orig Mon Sep 30 13:20:38 2002
-+++ graal/src/GMX_motif.c Thu May 26 15:04:42 2005
-@@ -92,7 +92,6 @@
-
- {
- "*.GraalMainWindow.iconName : Graal",
-- "*GraalMenuBar*fontList : -*-helvetica-bold-r-*--14-*",
- "*foreground : black",
- "*background : gray",
- "*fontList : -*-helvetica-medium-r-*--12-*",
---- xfsm/src/XMX_motif.c.orig Mon Sep 30 13:21:40 2002
-+++ xfsm/src/XMX_motif.c Thu May 26 15:04:46 2005
-@@ -93,7 +93,6 @@
-
- {
- "*.XfsmMainWindow.iconName : Xfsm",
-- "*XfsmMenuBar*fontList : -*-helvetica-bold-r-*--14-*",
- "*foreground : black",
- "*background : gray",
- "*fontList : -*-helvetica-medium-r-*--12-*",
---- xpat/src/XMX_motif.c.orig Mon Sep 30 13:21:47 2002
-+++ xpat/src/XMX_motif.c Thu May 26 15:04:52 2005
-@@ -91,7 +91,6 @@
-
- {
- "*.XpatMainWindow.iconName : Xpat",
-- "*XpatMenuBar*fontList : -*-helvetica-bold-r-*--14-*",
- "*foreground : black",
- "*background : gray",
- "*fontList : -*-helvetica-medium-r-*--12-*",
---- xsch/src/XMX_motif.c.orig Mon Sep 30 13:21:58 2002
-+++ xsch/src/XMX_motif.c Thu May 26 15:05:02 2005
-@@ -92,7 +92,6 @@
-
- {
- "*.XschMainWindow.iconName : Xsch",
-- "*XschMenuBar*fontList : -*-helvetica-bold-r-*--14-*",
- "*foreground : black",
- "*background : gray",
- "*fontList : -*-helvetica-medium-r-*--12-*",
---- xvpn/src/XMX_motif.c.orig Mon Sep 30 13:22:14 2002
-+++ xvpn/src/XMX_motif.c Thu May 26 15:05:06 2005
-@@ -92,7 +92,6 @@
-
- {
- "*.XvpnMainWindow.iconName : Xvpn",
-- "*XvpnMenuBar*fontList : -*-helvetica-bold-r-*--14-*",
- "*foreground : black",
- "*background : gray",
- "*fontList : -*-helvetica-medium-r-*--12-*",
diff --git a/cad/alliance/files/patch-asimut_src_Makefile.in b/cad/alliance/files/patch-asimut_src_Makefile.in
new file mode 100644
index 000000000000..7fc277f28c9d
--- /dev/null
+++ b/cad/alliance/files/patch-asimut_src_Makefile.in
@@ -0,0 +1,22 @@
+--- asimut/src/Makefile.in.orig 2012-05-14 14:46:17 UTC
++++ asimut/src/Makefile.in
+@@ -451,8 +451,6 @@ libCst_la_LDFLAGS = -version-info @CST_D
+ libSch_la_LDFLAGS = -version-info @SCH_DLL_VERSION@
+ asimut_LDADD = \
+ -lBvl \
+--lBhl \
+--L. libCst.la libSch.la \
+ -L$(top_builddir)/mbkvti/src \
+ -L$(top_builddir)/mbkedif/src \
+ -L$(top_builddir)/mbkhilo/src \
+@@ -473,7 +471,9 @@ asimut_LDADD = \
+ -lMlu \
+ -lMal \
+ -lMcl -lMel -lMhl -lMgl -lMsl \
+- -lMvg -lMlo -lRcn -lBvl -lBeh -lPpt -lPhl -lPat -lLog -lMut
++-lMvg -lMlo -lRcn -lBeh -lPpt -lPhl -lPat -lLog -lMut \
++-lBhl \
++-L. libCst.la libSch.la
+
+ asimut_SOURCES = \
+ beh_delay.h c_fsyn_sr1k_56.c vh_debug.c vh_lspec.c vh_util.h \
diff --git a/cad/alliance/files/patch-distrib-etc-Makefile.am b/cad/alliance/files/patch-distrib-etc-Makefile.am
deleted file mode 100644
index 15b08957e2f1..000000000000
--- a/cad/alliance/files/patch-distrib-etc-Makefile.am
+++ /dev/null
@@ -1,10 +0,0 @@
---- distrib/etc/Makefile.am.orig 2009-12-07 00:51:37.000000000 +0900
-+++ distrib/etc/Makefile.am 2009-12-07 00:51:49.000000000 +0900
-@@ -1,6 +1,6 @@
- # $Id: Makefile.am,v 1.5 2009/09/01 21:33:39 jpc Exp $
-
--etcdir=/etc/profile.d
-+etcdir=$(prefix)/etc/profile.d
-
- etc_SCRIPTS=alc_env.csh alc_env.sh
-
diff --git a/cad/alliance/files/patch-elp_src_elp.c b/cad/alliance/files/patch-elp_src_elp.c
new file mode 100644
index 000000000000..c5def961c2aa
--- /dev/null
+++ b/cad/alliance/files/patch-elp_src_elp.c
@@ -0,0 +1,44 @@
+--- elp/src/elp.c.orig 2002-06-12 12:54:39 UTC
++++ elp/src/elp.c
+@@ -62,6 +62,7 @@ elpFCT elpenv()
+ if ( str == (char *)NULL ) str = ALLIANCE_TOP;
+ sprintf( elpTechnoFile, "%s/%s", str, TECHNOLOGY );
+ }
++ return (0);
+ }
+
+ /*****************************************************************************/
+@@ -249,7 +250,7 @@ if(elpGeneral[elpACM] == 1.0)
+ lotrs->PS = lotrs->PD = lotrs->WIDTH ;
+ }
+
+-return ;
++return 0;
+ }
+
+
+@@ -457,7 +458,7 @@ if((lotrs->PS != 0.0) && (lotrs->XS != 0
+ addcapa( lotrs->SOURCE->SIG, elpLotrsCapaSource(lotrs) ) ;
+ }
+
+-return ;
++return 0;
+ }
+
+
+@@ -487,7 +488,7 @@ for(lotrs = lofig->LOTRS ; lotrs != NULL
+
+ addcapa( lotrs->GRID->SIG, elpLotrsCapaGrid(lotrs) );
+ }
+-return ;
++return 0;
+ }
+
+
+@@ -515,5 +516,5 @@ lotrs_list *lotrs ;
+ for(lotrs = lofig->LOTRS ; lotrs != NULL ; lotrs = lotrs->NEXT)
+ elpLotrsShrink(lotrs) ;
+
+-return ;
++return 0;
+ }
diff --git a/cad/alliance/files/patch-exp__src__ht.c b/cad/alliance/files/patch-exp__src__ht.c
deleted file mode 100644
index 4ba85f65659b..000000000000
--- a/cad/alliance/files/patch-exp__src__ht.c
+++ /dev/null
@@ -1,7 +0,0 @@
---- exp/src/ht.c.orig Thu May 6 08:41:16 2004
-+++ exp/src/ht.c Thu May 6 08:41:35 2004
-@@ -1,3 +1,4 @@
-+#include <sys/types.h>
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
diff --git a/cad/alliance/files/patch-ppt_src_Makefile.in b/cad/alliance/files/patch-ppt_src_Makefile.in
new file mode 100644
index 000000000000..bd55f80d96c3
--- /dev/null
+++ b/cad/alliance/files/patch-ppt_src_Makefile.in
@@ -0,0 +1,11 @@
+--- ppt/src/Makefile.in.orig 2012-05-14 14:46:35 UTC
++++ ppt/src/Makefile.in
+@@ -769,7 +769,7 @@ pat_decl_y.c pat_decl_y.h : $(srcdir)/pa
+ $(YACC) -d $(YFLAGS) $(srcdir)/pat_decl_y.y \
+ && sed -e "s/yy/pat_decl_y_/g" -e "s/YY/PAT_DECL_Y_/g" y.tab.c \
+ | sed -e "s/int[ ]*pat_decl_y_char;/extern int pat_decl_y_char;/" \
+- | sed -e "s/PAT_DECL_Y_STYPE[ ]*pat_decl_y_lval;/extern PAT_DECL_Y_STYPE pat_decl_y_lval;/" \
++ | sed -e "s/PAT_DECL_Y_STYPE[ ]*pat_decl_y_lval;/PAT_DECL_Y_STYPE pat_decl_y_lval;/" \
+ | sed -e "s/int[ ]*pat_decl_y_nerrs;/extern int pat_decl_y_nerrs;/" \
+ > pat_decl_y.c \
+ && sed -e "s/yy/pat_decl_y_/g" -e "s/YY/PAT_DECL_Y_/g" y.tab.h > pat_decl_y.h
diff --git a/cad/alliance/files/patch-sea__src__sea.sh b/cad/alliance/files/patch-sea__src__sea.sh
deleted file mode 100644
index 585e4f470b42..000000000000
--- a/cad/alliance/files/patch-sea__src__sea.sh
+++ /dev/null
@@ -1,19 +0,0 @@
---- sea/src/sea.sh.orig Sun May 9 03:42:49 2004
-+++ sea/src/sea.sh Sun May 9 03:43:32 2004
-@@ -376,11 +376,11 @@
- exit 1
- fi
-
-- if [ "`uname`" != "SunOS" ]; then
-- echo "sea.sh:error: Must be run only under Solaris OS."
-- echo " (current OS : \"$ALLIANCE_OS\")"
-- exit 1
-- fi
-+ #if [ "`uname`" != "SunOS" ]; then
-+ # echo "sea.sh:error: Must be run only under Solaris OS."
-+ # echo " (current OS : \"$ALLIANCE_OS\")"
-+ # exit 1
-+ #fi
-
-
- if [ "$devel" = "y" ]; then
diff --git a/cad/alliance/files/patch-sea__src__seplace.sh b/cad/alliance/files/patch-sea__src__seplace.sh
deleted file mode 100644
index 6baf95c11d43..000000000000
--- a/cad/alliance/files/patch-sea__src__seplace.sh
+++ /dev/null
@@ -1,17 +0,0 @@
---- sea/src/seplace.sh.orig Sun May 9 07:29:32 2004
-+++ sea/src/seplace.sh Sun May 9 07:29:49 2004
-@@ -225,10 +225,10 @@
- title
-
-
-- if [ "`uname`" != "SunOS" ]; then
-- echo "seplace.sh:error: This progam must be run under Solaris."
-- exit 1
-- fi
-+ #if [ "`uname`" != "SunOS" ]; then
-+ # echo "seplace.sh:error: This progam must be run under Solaris."
-+ # exit 1
-+ #fi
-
-
- # --------------------------------------------------------------------
diff --git a/cad/alliance/files/patch-sea__src__seroute.sh b/cad/alliance/files/patch-sea__src__seroute.sh
deleted file mode 100644
index c45ba45066e3..000000000000
--- a/cad/alliance/files/patch-sea__src__seroute.sh
+++ /dev/null
@@ -1,17 +0,0 @@
---- sea/src/seroute.sh.orig Sun May 9 03:43:37 2004
-+++ sea/src/seroute.sh Sun May 9 03:43:53 2004
-@@ -226,10 +226,10 @@
- title
-
-
-- if [ "`uname`" != "SunOS" ]; then
-- echo "seplace.sh:error: This progam must be run under Solaris."
-- exit 1
-- fi
-+ #if [ "`uname`" != "SunOS" ]; then
-+ # echo "seplace.sh:error: This progam must be run under Solaris."
-+ # exit 1
-+ #fi
-
-
- # --------------------------------------------------------------------
diff --git a/cad/alliance/files/patch-xgra-src-XSB_parse.c b/cad/alliance/files/patch-xgra-src-XSB_parse.c
deleted file mode 100644
index 719579cade43..000000000000
--- a/cad/alliance/files/patch-xgra-src-XSB_parse.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- xgra/src/XSB_parse.c.orig 2009-11-30 01:53:57.000000000 +0900
-+++ xgra/src/XSB_parse.c 2009-11-30 01:54:08.000000000 +0900
-@@ -43,7 +43,6 @@
- | |
- \------------------------------------------------------------*/
-
--# include <malloc.h>
- # include <stdlib.h>
- # include <string.h>
- # include "mut.h"