aboutsummaryrefslogtreecommitdiff
path: root/cad/alliance/files
diff options
context:
space:
mode:
Diffstat (limited to 'cad/alliance/files')
-rw-r--r--cad/alliance/files/patch-06-fix-format-strings95
-rw-r--r--cad/alliance/files/patch-11-fix-segfaults115
-rw-r--r--cad/alliance/files/patch-asimut_src_Makefile.in22
-rw-r--r--cad/alliance/files/patch-documentation_tutorials_start_start.tex15
-rw-r--r--cad/alliance/files/patch-elp_src_elp.c44
-rw-r--r--cad/alliance/files/patch-ppt_src_Makefile.in11
6 files changed, 15 insertions, 287 deletions
diff --git a/cad/alliance/files/patch-06-fix-format-strings b/cad/alliance/files/patch-06-fix-format-strings
deleted file mode 100644
index 8b5faa79a1f0..000000000000
--- a/cad/alliance/files/patch-06-fix-format-strings
+++ /dev/null
@@ -1,95 +0,0 @@
-Description: Format string fixes
- This patch fixes some format string problems with fprintf().
-Author: Roland Stigge <stigge@antcom.de>
-
-===================================================================
---- alliance-5.0-20110203.orig/rtd/src/rtd_drive.c 2002-09-30 18:21:10.000000000 +0200
-+++ rtd/src/rtd_drive.c 2012-03-24 15:24:00.000000000 +0100
-@@ -100,7 +100,7 @@
- RtlExprLength = Length;
- }
-
-- fprintf( RtlFile, Name );
-+ fprintf( RtlFile, "%s", Name );
- }
-
- /*------------------------------------------------------------\
-===================================================================
---- alliance-5.0-20110203.orig/vpd/src/vpd_drive.c 2002-09-30 18:21:32.000000000 +0200
-+++ vpd/src/vpd_drive.c 2012-03-24 15:37:53.000000000 +0100
-@@ -100,7 +100,7 @@
- VpnExprLength = Length;
- }
-
-- fprintf( VpnFile, Name );
-+ fprintf( VpnFile, "%s", Name );
- }
-
- /*------------------------------------------------------------\
-===================================================================
---- alliance-5.0-20110203.orig/boog/src/bog_normalize_message.c 2002-09-30 18:19:58.000000000 +0200
-+++ boog/src/bog_normalize_message.c 2012-03-24 15:50:03.000000000 +0100
-@@ -106,7 +106,7 @@
- }
-
- fprintf(stderr,"BEH: ");
-- fprintf(stderr,message);
-+ fprintf(stderr,"%s",message);
- fprintf(stderr," in '");
- fflush(stderr);
- display_abl(abl);
-===================================================================
---- alliance-5.0-20110203.orig/l2p/src/drive_ps.c 2005-02-17 16:34:44.000000000 +0100
-+++ l2p/src/drive_ps.c 2012-03-24 16:02:33.000000000 +0100
-@@ -83,22 +83,22 @@
- break;
- case E_OPEN :
- fprintf (stderr, "Problem while opening file ");
-- fprintf (stderr, msg);
-+ fprintf (stderr, "%s", msg);
- break;
- case E_CLOSE :
- fprintf (stderr, "Problem while closing file ");
-- fprintf (stderr, msg);
-+ fprintf (stderr, "%s", msg);
- break;
- case E_WRITE :
- fprintf (stderr, "Problem while writing file ");
-- fprintf (stderr, msg);
-+ fprintf (stderr, "%s", msg);
- break;
- case E_READ :
- fprintf (stderr, "Problem while reading file ");
-- fprintf (stderr, msg);
-+ fprintf (stderr, "%s", msg);
- break;
- case E_OUTBOX :
-- fprintf (stderr, msg);
-+ fprintf (stderr, "%s", msg);
- break;
- default :
- fprintf (stderr, "Unknow internal error");
-===================================================================
---- alliance-5.0-20110203.orig/loon/src/lon_normalize_message.c 2004-09-06 23:26:09.000000000 +0200
-+++ loon/src/lon_normalize_message.c 2012-03-24 16:15:39.000000000 +0100
-@@ -106,7 +106,7 @@
- }
-
- fprintf(stderr,"BEH: ");
-- fprintf(stderr,message);
-+ fprintf(stderr,"%s",message);
- fprintf(stderr," in '");
- fflush(stderr);
- display_abl(abl);
-===================================================================
---- alliance-5.0-20110203.orig/sea/src/util_LEFDEF.c 2004-09-29 23:40:46.000000000 +0200
-+++ sea/src/util_LEFDEF.c 2012-03-24 16:36:27.000000000 +0100
-@@ -213,7 +213,7 @@
- *pI = (char)0; pI += 1;
- sprintf (asLEF, "%s(%s)", sTmp, pI);
- } else {
-- sprintf (asLEF, sTmp);
-+ sprintf (asLEF, "%s", sTmp);
- }
-
- return (asLEF);
diff --git a/cad/alliance/files/patch-11-fix-segfaults b/cad/alliance/files/patch-11-fix-segfaults
deleted file mode 100644
index cc7b6fa72457..000000000000
--- a/cad/alliance/files/patch-11-fix-segfaults
+++ /dev/null
@@ -1,115 +0,0 @@
-Description: Fix segfaults in different executables
- Some executables in the package crashed upon certain command line option
- combinations. This patch fixes this.
-Author: Roland Stigge <stigge@antcom.de>
-Bug-Debian: http://bugs.debian.org/715651
-Bug-Debian: http://bugs.debian.org/716217
-Bug-Debian: http://bugs.debian.org/716529
-
---- alliance-5.0-20120515.orig/asimut/src/vh_simulad.c
-+++ asimut/src/vh_simulad.c
-@@ -155,8 +155,8 @@ char **argv;
- arg_flg [i ] = 1;
- }
-
-- if ((!strcmp (argv [i], "-fixeddelay"))
-- || (!strcmp (argv [i], "-fd")))
-+ if (((!strcmp (argv [i], "-fixeddelay"))
-+ || (!strcmp (argv [i], "-fd"))) && (argc > i + 1))
- {
- fixdly_flg = 1;
- delay_mode |= BEH_DELAY_FIXED;
-@@ -165,8 +165,8 @@ char **argv;
- arg_flg [i+1] = 1;
- }
-
-- if ((!strcmp (argv [i], "-backdelay"))
-- || (!strcmp (argv [i], "-bd")))
-+ if (((!strcmp (argv [i], "-backdelay"))
-+ || (!strcmp (argv [i], "-bd"))) && (argc > i + 1))
- {
- bckdly_flg = i + 2;
- delay_mode |= BEH_DELAY_BACKANOTATED;
-@@ -221,14 +221,14 @@ char **argv;
- arg_flg [i] = 1;
- }
-
-- if (!strcmp (argv [i], "-p"))
-+ if (!strcmp (argv [i], "-p") && (argc > i + 1))
- {
- sscanf (argv [i+1], "%u", &max_pat);
- arg_flg [i ] = 1;
- arg_flg [i+1] = 1;
- }
-
-- if (!strcmp (argv [i], "-l"))
-+ if (!strcmp (argv [i], "-l") && (argc > i + 1))
- {
- sscanf (argv [i+1], "%u", &labelsiz);
- arg_flg [i ] = 1;
-@@ -241,7 +241,7 @@ char **argv;
- arg_flg [i] = 1;
- }
-
-- if (!strcmp (argv [i], "-stat"))
-+ if (!strcmp (argv [i], "-stat") && (argc > i + 1))
- {
- stat_flg = i + 2;
- sscanf (argv [i+1], "%u", &ref_date);
-@@ -264,7 +264,7 @@ char **argv;
- arg_flg [i+1] = 1;
- }
-
-- if (!strcmp (argv [i], "-inspect"))
-+ if (!strcmp (argv [i], "-inspect") && (argc > i + 1))
- {
- str = namealloc (argv [i+1]);
- pt_pains = pat_addpains (pt_pains, str, str);
---- alliance-5.0-20120515.orig/m2e/src/m2e.c
-+++ m2e/src/m2e.c
-@@ -102,6 +102,8 @@ int ParseCommand(int argc,char *argv[])
- switch(argv[i][1])
- {
- case 'v':
-+ if (argc <= i + 1)
-+ break;
- i++;
- sscanf(argv[i],"%d",&VerboseMode);
- if(VerboseMode>=VMINFO)
-@@ -109,6 +111,8 @@ int ParseCommand(int argc,char *argv[])
- break;
-
- case 'o':
-+ if (argc <= i + 1)
-+ break;
- i++;
- OutputName=argv[i];
- if(VerboseMode>=VMINFO)
---- alliance-5.0-20120515.orig/mips_asm/src/mips_y.y
-+++ mips_asm/src/mips_y.y
-@@ -92,14 +92,14 @@ char *argv [];
- {
- if (arg_flg [i] == 0)
- {
-- if (!strcmp (argv[i], "-textsize"))
-+ if (!strcmp (argv[i], "-textsize") && argc > i + 1)
- {
- sscanf (argv[i+1], "%u", &txt_siz);
- arg_flg [i ] = 1;
- arg_flg [i+1] = 1;
- }
-
-- if (!strcmp (argv[i], "-datasize"))
-+ if (!strcmp (argv[i], "-datasize") && argc > i + 1)
- {
- sscanf (argv[i+1], "%u", &dat_siz);
- arg_flg [i ] = 1;
-@@ -112,7 +112,7 @@ char *argv [];
- arg_flg [i] = 1 ;
- }
-
-- if (!strcmp (argv[i], "-symbol"))
-+ if (!strcmp (argv[i], "-symbol") && argc > i + 1)
- {
- MPS_SYMBOL = 'y' ;
- symbol_fil = argv [i+1];
diff --git a/cad/alliance/files/patch-asimut_src_Makefile.in b/cad/alliance/files/patch-asimut_src_Makefile.in
deleted file mode 100644
index 7fc277f28c9d..000000000000
--- a/cad/alliance/files/patch-asimut_src_Makefile.in
+++ /dev/null
@@ -1,22 +0,0 @@
---- asimut/src/Makefile.in.orig 2012-05-14 14:46:17 UTC
-+++ asimut/src/Makefile.in
-@@ -451,8 +451,6 @@ libCst_la_LDFLAGS = -version-info @CST_D
- libSch_la_LDFLAGS = -version-info @SCH_DLL_VERSION@
- asimut_LDADD = \
- -lBvl \
---lBhl \
---L. libCst.la libSch.la \
- -L$(top_builddir)/mbkvti/src \
- -L$(top_builddir)/mbkedif/src \
- -L$(top_builddir)/mbkhilo/src \
-@@ -473,7 +471,9 @@ asimut_LDADD = \
- -lMlu \
- -lMal \
- -lMcl -lMel -lMhl -lMgl -lMsl \
-- -lMvg -lMlo -lRcn -lBvl -lBeh -lPpt -lPhl -lPat -lLog -lMut
-+-lMvg -lMlo -lRcn -lBeh -lPpt -lPhl -lPat -lLog -lMut \
-+-lBhl \
-+-L. libCst.la libSch.la
-
- asimut_SOURCES = \
- beh_delay.h c_fsyn_sr1k_56.c vh_debug.c vh_lspec.c vh_util.h \
diff --git a/cad/alliance/files/patch-documentation_tutorials_start_start.tex b/cad/alliance/files/patch-documentation_tutorials_start_start.tex
new file mode 100644
index 000000000000..0310e02dfab4
--- /dev/null
+++ b/cad/alliance/files/patch-documentation_tutorials_start_start.tex
@@ -0,0 +1,15 @@
+Add "float" package to avoid "Unknown float option 'H'" error
+
+Obtained from Debian
+
+--- documentation/tutorials/start/start.tex.orig 2014-08-02 23:38:00 UTC
++++ documentation/tutorials/start/start.tex
+@@ -9,7 +9,7 @@
+ %
+ %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
+ \documentclass{article}
+-\usepackage{charter,setspace,fancybox}
++\usepackage{charter,setspace,fancybox,float}
+ \textwidth 15cm
+ \textheight 23cm
+ \oddsidemargin +0.75cm
diff --git a/cad/alliance/files/patch-elp_src_elp.c b/cad/alliance/files/patch-elp_src_elp.c
deleted file mode 100644
index c5def961c2aa..000000000000
--- a/cad/alliance/files/patch-elp_src_elp.c
+++ /dev/null
@@ -1,44 +0,0 @@
---- elp/src/elp.c.orig 2002-06-12 12:54:39 UTC
-+++ elp/src/elp.c
-@@ -62,6 +62,7 @@ elpFCT elpenv()
- if ( str == (char *)NULL ) str = ALLIANCE_TOP;
- sprintf( elpTechnoFile, "%s/%s", str, TECHNOLOGY );
- }
-+ return (0);
- }
-
- /*****************************************************************************/
-@@ -249,7 +250,7 @@ if(elpGeneral[elpACM] == 1.0)
- lotrs->PS = lotrs->PD = lotrs->WIDTH ;
- }
-
--return ;
-+return 0;
- }
-
-
-@@ -457,7 +458,7 @@ if((lotrs->PS != 0.0) && (lotrs->XS != 0
- addcapa( lotrs->SOURCE->SIG, elpLotrsCapaSource(lotrs) ) ;
- }
-
--return ;
-+return 0;
- }
-
-
-@@ -487,7 +488,7 @@ for(lotrs = lofig->LOTRS ; lotrs != NULL
-
- addcapa( lotrs->GRID->SIG, elpLotrsCapaGrid(lotrs) );
- }
--return ;
-+return 0;
- }
-
-
-@@ -515,5 +516,5 @@ lotrs_list *lotrs ;
- for(lotrs = lofig->LOTRS ; lotrs != NULL ; lotrs = lotrs->NEXT)
- elpLotrsShrink(lotrs) ;
-
--return ;
-+return 0;
- }
diff --git a/cad/alliance/files/patch-ppt_src_Makefile.in b/cad/alliance/files/patch-ppt_src_Makefile.in
deleted file mode 100644
index bd55f80d96c3..000000000000
--- a/cad/alliance/files/patch-ppt_src_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- ppt/src/Makefile.in.orig 2012-05-14 14:46:35 UTC
-+++ ppt/src/Makefile.in
-@@ -769,7 +769,7 @@ pat_decl_y.c pat_decl_y.h : $(srcdir)/pa
- $(YACC) -d $(YFLAGS) $(srcdir)/pat_decl_y.y \
- && sed -e "s/yy/pat_decl_y_/g" -e "s/YY/PAT_DECL_Y_/g" y.tab.c \
- | sed -e "s/int[ ]*pat_decl_y_char;/extern int pat_decl_y_char;/" \
-- | sed -e "s/PAT_DECL_Y_STYPE[ ]*pat_decl_y_lval;/extern PAT_DECL_Y_STYPE pat_decl_y_lval;/" \
-+ | sed -e "s/PAT_DECL_Y_STYPE[ ]*pat_decl_y_lval;/PAT_DECL_Y_STYPE pat_decl_y_lval;/" \
- | sed -e "s/int[ ]*pat_decl_y_nerrs;/extern int pat_decl_y_nerrs;/" \
- > pat_decl_y.c \
- && sed -e "s/yy/pat_decl_y_/g" -e "s/YY/PAT_DECL_Y_/g" y.tab.h > pat_decl_y.h