aboutsummaryrefslogtreecommitdiff
path: root/cad/calculix/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/calculix/Makefile')
-rw-r--r--cad/calculix/Makefile23
1 files changed, 6 insertions, 17 deletions
diff --git a/cad/calculix/Makefile b/cad/calculix/Makefile
index 5ef8473bc89e..be354fd47990 100644
--- a/cad/calculix/Makefile
+++ b/cad/calculix/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= CalculiX
-PORTVERSION= 1.4
-PORTREVISION= 1
+PORTVERSION= 1.5
CATEGORIES= cad
MASTER_SITES= http://www.dhondt.de/
DISTFILES= ${DIST_SOURCES}
@@ -51,7 +50,6 @@ DIST_EXAMPLES= ccx_${PORTVERSION}.test${EXTRACT_SUFX} \
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
USE_GL= yes
-USE_REINPLACE= yes
BLAS_LIBS?= -lf77blas -latlas
BROWSER?= mozilla
@@ -63,6 +61,11 @@ PSVIEWER?= gv
USE_GCC= 3.4
.endif
+.if ${ARCH} == "amd64"
+FFLAGS+= -fPIC
+CFLAGS+= -fPIC
+.endif
+
.if !defined(WITH_EXAMPLES)
PLIST_SUB= WITH_EXAMPLES="@comment "
.else
@@ -89,20 +92,6 @@ pre-build:
s+"mozilla"+"${BROWSER}"+ ; \
s+"ghostview"+"${PSVIEWER}"+ ;' \
${WRKSRC}/cgx_${PORTVERSION}/src/cgx.h
-# This fixes bugs in ccx 1.4
- @${REINPLACE_CMD} -e 's+description[12]+description[13]+g;' \
- ${WRKSRC}/ccx_1.4/src/arpackbu.c \
- ${WRKSRC}/ccx_1.4/src/arpack.c \
- ${WRKSRC}/ccx_1.4/src/arpackcs.c \
- ${WRKSRC}/ccx_1.4/src/dyna.c \
- ${WRKSRC}/ccx_1.4/src/frdcyc.c \
- ${WRKSRC}/ccx_1.4/src/nonlingeo.c \
- ${WRKSRC}/ccx_1.4/src/prespooles.c \
- ${WRKSRC}/ccx_1.4/src/profile.c \
- ${WRKSRC}/ccx_1.4/src/sensitivity.c \
- ${WRKSRC}/ccx_1.4/src/steadystate.c
- @${REINPLACE_CMD} -e 's+output[3]+output[4]+g;' \
- ${WRKSRC}/ccx_1.4/src/ccx_1.4.c
do-build:
@(cd ${WRKSRC}/ccx_${PORTVERSION}/src; ${SETENV} ${MAKE_ENV} $(GMAKE) )