aboutsummaryrefslogtreecommitdiff
path: root/cad/fasm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/fasm/Makefile')
-rw-r--r--cad/fasm/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/cad/fasm/Makefile b/cad/fasm/Makefile
new file mode 100644
index 000000000000..96f254c620d5
--- /dev/null
+++ b/cad/fasm/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= fasm
+PORTVERSION= g20190920
+CATEGORIES= cad python
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= FPGA assembly (FASM) parser and generator
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}textX>0:lang/py-textX@${PY_FLAVOR}
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= SymbiFlow
+GH_TAGNAME= b8db365
+USE_PYTHON= distutils concurrent noflavors autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>