aboutsummaryrefslogtreecommitdiff
path: root/cad/geda-utils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/geda-utils/Makefile')
-rw-r--r--cad/geda-utils/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/cad/geda-utils/Makefile b/cad/geda-utils/Makefile
new file mode 100644
index 000000000000..95ce3603c73c
--- /dev/null
+++ b/cad/geda-utils/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: geda
+# Date created: 4 April 2001
+# Whom: bruno schwander <bruno@tinkerbox.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= utils
+PORTVERSION= 20020825
+CATEGORIES= cad
+MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/devel/${PORTVERSION}/ \
+ http://geda.seul.org/devel/${PORTVERSION}/ \
+ http://www.tinkerbox.org/projects/files/gEDA/
+DISTNAME= geda-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= bruno@tinkerbox.org
+
+BUILD_DEPENDS= gesym-config:${PORTSDIR}/cad/geda-symbols
+LIB_DEPENDS= geda.16:${PORTSDIR}/cad/libgeda \
+ guile.10:${PORTSDIR}/lang/guile
+
+USE_LIBTOOL= yes
+#USE_AUTOCONF= yes
+AUTOCONF= autoconf
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --enable-gdgeda
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>