aboutsummaryrefslogtreecommitdiff
path: root/cad/kicad/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/kicad/Makefile')
-rw-r--r--cad/kicad/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/cad/kicad/Makefile b/cad/kicad/Makefile
index 034254e5c974..287814ed60ad 100644
--- a/cad/kicad/Makefile
+++ b/cad/kicad/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kicad
PORTVERSION= 4.0.7
-PORTREVISION= 6
+PORTREVISION= 7
PORTEPOCH= 2
CATEGORIES= cad
@@ -59,6 +59,12 @@ DOXYGEN_IMPLIES= DOCS
DOXYGEN_ALL_TARGET= all doxygen-docs
DOXYGEN_PORTDOCS= doxygen
+# The CheckCXXSymbolExists module has been shipped with CMake since 3.0 times.
+# The ancient implementation that this bundled module uses, no longer works
+# because it uses CMake internals that have gone away in 3.11.
+post-extract:
+ ${RM} ${WRKSRC}/CMakeModules/CheckCXXSymbolExists.cmake
+
pre-configure:
${REINPLACE_CMD} -e 's|/usr/share/kicad|${DATADIR}|' \
-e 's|/usr/local|${PREFIX}|' \