aboutsummaryrefslogtreecommitdiff
path: root/cad/netgen/files/patch-togl::Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/netgen/files/patch-togl::Makefile')
-rw-r--r--cad/netgen/files/patch-togl::Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/cad/netgen/files/patch-togl::Makefile b/cad/netgen/files/patch-togl::Makefile
new file mode 100644
index 000000000000..6a7bf9b01e30
--- /dev/null
+++ b/cad/netgen/files/patch-togl::Makefile
@@ -0,0 +1,43 @@
+--- ./togl/Makefile.orig Wed Jan 28 16:28:33 2004
++++ ./togl/Makefile Sun Nov 21 18:37:12 2004
+@@ -57,33 +57,33 @@
+ # Initial revision
+ #
+
+-
++include ../libsrc/makefile.mach.$(MACHINE)
+
+ # Makefile for Togl demos
+ # You'll probably have to tinker with these macros:
+
+
+ # The C compiler:
+-CC = cc
++CC = $(CPLUSPLUS)
+
+ # Compiler options:
+-COPTS = -c -O
++COPTS = -c $(CXXFLAGS)
+
+ # Shared library linker command:
+-SHLINK = cc -G
++SHLINK = $(LINK) -shared
+
+ # Name for the shared lib:
+ #SH_LIB = libtogl.so.1.3
+ SH_LIB =
+
+ # Where to find tcl.h, tk.h, OpenGL/Mesa headers, etc:
+-INCLUDES = -I/usr/local/include -I/usr/include/tcl -I/usr/freeware/include
++INCLUDES = -I$(X11BASE)/include $(CPLUSPLUSFLAGS3)
+
+ # Where to find libtcl.a, libtk.a, OpenGL/Mesa libraries:
+-LIBDIRS = -L/usr/local/lib
++LIBDIRS = $(LINKFLAGS2)
+
+ # Libraries to link with (-ldl for Linux only?):
+-LIBS = -ltk -ltcl -lGLU -lGL -L/usr/X11/lib -L/usr/freeware/lib32 -lX11 -lXmu -lXext -lXt -lm -ldl
++LIBS = $(tcltklib) -lGLU -lGL -lX11 -lXmu -lXext -lXt -lm
+
+ TK_FLAGS =
+