aboutsummaryrefslogtreecommitdiff
path: root/cad/openscad/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/openscad/Makefile')
-rw-r--r--cad/openscad/Makefile32
1 files changed, 12 insertions, 20 deletions
diff --git a/cad/openscad/Makefile b/cad/openscad/Makefile
index 57a8460c78b9..3ae00826f82d 100644
--- a/cad/openscad/Makefile
+++ b/cad/openscad/Makefile
@@ -12,26 +12,22 @@ COMMENT= The programmer's solid 3D CAD modeller
LICENSE= GPLv2
-BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison \
- ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
+BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2 \
${LOCALBASE}/include/boost/tuple/tuple.hpp:${PORTSDIR}/devel/boost-libs
-LIB_DEPENDS= GLU:${PORTSDIR}/graphics/libGLU \
- gmp:${PORTSDIR}/math/gmp \
- mpfr:${PORTSDIR}/math/mpfr \
- CGAL:${PORTSDIR}/math/cgal \
- opencsg:${PORTSDIR}/graphics/opencsg
-
-USE_GL= glew
-USE_QT4= qmake corelib gui opengl moc uic rcc
-PLIST_SUB= PORTVERSION=${PORTVERSION}
-#MAKE_JOBS_UNSAFE=yes
-QMAKE_ENV = EIGEN2DIR=${LOCALBASE}/include/eigen2
-QMAKE_FLAGS = VERSION=${PORTVERSION}
-MAKE_ENV = INSTALL_ROOT=${DESTDIR}
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
+ libmpfr.so:${PORTSDIR}/math/mpfr \
+ libCGAL.so:${PORTSDIR}/math/cgal \
+ libopencsg.so:${PORTSDIR}/graphics/opencsg
+
+USES= bison qmake
+USE_GL= glu glew
+USE_QT4= corelib gui opengl moc_build uic_build rcc_build
+PLIST_SUB= PORTVERSION=${PORTVERSION}
+QMAKE_ENV= EIGEN2DIR=${LOCALBASE}/include/eigen2
+QMAKE_ARGS+= VERSION=${PORTVERSION}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's,XXXFLEXXX,"${LOCALBASE}/bin/flex",' \
${WRKSRC}/openscad.pro
@@ -42,8 +38,4 @@ post-patch:
${REINPLACE_CMD} -e 's#/usr/local/bin/flex#${LOCALBASE}/bin/flex#g' \
${WRKSRC}/flex.pri
-do-configure:
- cd ${WRKSRC} && \
- ${SETENV} ${QMAKE_ENV} ${QMAKE} ${QMAKE_FLAGS} openscad.pro
-
.include <bsd.port.mk>