aboutsummaryrefslogtreecommitdiff
path: root/cad/qcad-partslib
diff options
context:
space:
mode:
Diffstat (limited to 'cad/qcad-partslib')
-rw-r--r--cad/qcad-partslib/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/cad/qcad-partslib/Makefile b/cad/qcad-partslib/Makefile
index c17ef95e676b..52cf4b6ffec3 100644
--- a/cad/qcad-partslib/Makefile
+++ b/cad/qcad-partslib/Makefile
@@ -28,12 +28,14 @@ PLIST= ${WRKDIR}/pkg-plist
.include <bsd.port.pre.mk>
pre-install:
+ @${ECHO_CMD} '@exec mkdir -p %D/share/qcad/libraries' > ${PLIST}
@${FIND} ${WRKSRC} -type f | \
- ${SED} -e "s:^${WRKSRC}/:share/qcad/library/:g" > ${PLIST}
- @${FIND} -d ${WRKSRC}/* -type d | \
+ ${SED} -e "s:^${WRKSRC}/:share/qcad/library/:g" >> ${PLIST}
+ @${FIND} -d ${WRKSRC} -type d | \
${SED} -e "s:^${WRKSRC}:@dirrm share/qcad/library:g" >> ${PLIST}
do-install:
+ @${MKDIR} ${DATADIR}
${TAR} -C ${WRKSRC} --exclude CVS -cf - . | \
${TAR} -C ${DATADIR} --unlink -xf -