aboutsummaryrefslogtreecommitdiff
path: root/cad/repsnapper/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/repsnapper/Makefile')
-rw-r--r--cad/repsnapper/Makefile22
1 files changed, 7 insertions, 15 deletions
diff --git a/cad/repsnapper/Makefile b/cad/repsnapper/Makefile
index 10e622c2afad..3f3c437d4886 100644
--- a/cad/repsnapper/Makefile
+++ b/cad/repsnapper/Makefile
@@ -2,13 +2,8 @@
# $FreeBSD$
PORTNAME= repsnapper
-PORTVERSION= 2.3.2a3
-PORTREVISION= 7
+DISTVERSION= 2.5a4
CATEGORIES= cad
-MASTER_SITES= https://codeload.github.com/timschmidt/repsnapper/tar.gz/
-DISTNAME= ${PORTVERSION}
-EXTRACT_SUFX= #
-DIST_SUBDIR= ${PORTNAME}
MAINTAINER= martin.dieringer@gmx.de
COMMENT= Controller and GCode generator for RepRap 3D printers
@@ -17,11 +12,13 @@ LICENSE= GPLv2 BSD3CLAUSE MIT
LICENSE_COMB= multi
LIB_DEPENDS= libgtkglextmm-x11-1.2.so:x11-toolkits/gtkglextmm \
- libzip.so:archivers/libzip \
+ libzip.so:archivers/libzip
+BUILD_DEPENDS+= clang40:devel/llvm40
-BROKEN= fails to compile: ustring.h: expected ';' at end of declaration list
+USE_GITHUB= yes
+GH_ACCOUNT= timschmidt
-USES= autoreconf gmake libtool perl5 pkgconfig
+USES= compiler:c++11-lib autoreconf gmake libtool perl5 pkgconfig gettext
USE_GNOME= gtkmm24 intltool libxml++26
USE_GL= gl
USE_PERL5= build
@@ -29,12 +26,7 @@ GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= NLS
-OPTIONS_SUB= yes
-NLS_CONFIGURE_ENABLE= nls
-NLS_USES= gettext
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
INSTALL_TARGET= install-strip
post-install: