aboutsummaryrefslogtreecommitdiff
path: root/cad/spice/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/spice/files/Makefile')
-rw-r--r--cad/spice/files/Makefile16
1 files changed, 5 insertions, 11 deletions
diff --git a/cad/spice/files/Makefile b/cad/spice/files/Makefile
index f0c37acfcc1d..839a4d05e48c 100644
--- a/cad/spice/files/Makefile
+++ b/cad/spice/files/Makefile
@@ -1,22 +1,16 @@
#
# $FreeBSD$
#
-
-.ifdef WITHOUT_X11
-CONFIG= FreeBSD.without_x11
-.else
-CONFIG= FreeBSD
-.endif
-
all:
- util/build ${CONFIG} default
+ ${SH} util/build FreeBSD default
install:
mkdir -p ${DESTDIR}${PREFIX}/share/spice/helpdir \
${DESTDIR}${PREFIX}/share/spice/scripts
- (cd ${CONFIG}/obj/bin && ${BSD_INSTALL_PROGRAM} \
- spice3 nutmeg sconvert help proc2mod multidec \
- ${DESTDIR}${PREFIX}/bin)
+ cd FreeBSD/obj/bin && \
+ ${BSD_INSTALL_PROGRAM} \
+ spice3 nutmeg sconvert help proc2mod multidec \
+ ${DESTDIR}${PREFIX}/bin
${BSD_INSTALL_DATA} lib/helpdir/spice.txt \
${DESTDIR}${PREFIX}/share/spice/helpdir
${BSD_INSTALL_SCRIPT} lib/scripts/setplot lib/scripts/spinit \