aboutsummaryrefslogtreecommitdiff
path: root/cad/spice/files
diff options
context:
space:
mode:
Diffstat (limited to 'cad/spice/files')
-rw-r--r--cad/spice/files/FreeBSD5
-rw-r--r--cad/spice/files/FreeBSD.without_x113
-rw-r--r--cad/spice/files/Makefile16
3 files changed, 6 insertions, 18 deletions
diff --git a/cad/spice/files/FreeBSD b/cad/spice/files/FreeBSD
index bebc7251e090..990cd468d47e 100644
--- a/cad/spice/files/FreeBSD
+++ b/cad/spice/files/FreeBSD
@@ -1,8 +1,5 @@
# FreeBSD config exception file
-MAKE = /usr/bin/make
INTERFACE_OPTS = -DWANT_MFB -DWANT_X11
-CC = @CC@
-CC_OPT += @CFLAGS@
-LDFLAGS += -L@X11BASE@/lib -lm -ltermcap
+LDFLAGS += -L${LOCALBASE}/lib -lm -ltermcap
SYS_CFLAGS = -Dbsd
diff --git a/cad/spice/files/FreeBSD.without_x11 b/cad/spice/files/FreeBSD.without_x11
index 86d5651c97d8..73e2e28561f6 100644
--- a/cad/spice/files/FreeBSD.without_x11
+++ b/cad/spice/files/FreeBSD.without_x11
@@ -1,9 +1,6 @@
# FreeBSD config exception file (non-x11 version)
-MAKE = /usr/bin/make
INTERFACE_OPTS = -DWANT_MFB
-CC = @CC@
-CC_OPT += @CFLAGS@
LDFLAGS += -lm -ltermcap
SYS_CFLAGS = -Dbsd
X_DIR =
diff --git a/cad/spice/files/Makefile b/cad/spice/files/Makefile
index f0c37acfcc1d..839a4d05e48c 100644
--- a/cad/spice/files/Makefile
+++ b/cad/spice/files/Makefile
@@ -1,22 +1,16 @@
#
# $FreeBSD$
#
-
-.ifdef WITHOUT_X11
-CONFIG= FreeBSD.without_x11
-.else
-CONFIG= FreeBSD
-.endif
-
all:
- util/build ${CONFIG} default
+ ${SH} util/build FreeBSD default
install:
mkdir -p ${DESTDIR}${PREFIX}/share/spice/helpdir \
${DESTDIR}${PREFIX}/share/spice/scripts
- (cd ${CONFIG}/obj/bin && ${BSD_INSTALL_PROGRAM} \
- spice3 nutmeg sconvert help proc2mod multidec \
- ${DESTDIR}${PREFIX}/bin)
+ cd FreeBSD/obj/bin && \
+ ${BSD_INSTALL_PROGRAM} \
+ spice3 nutmeg sconvert help proc2mod multidec \
+ ${DESTDIR}${PREFIX}/bin
${BSD_INSTALL_DATA} lib/helpdir/spice.txt \
${DESTDIR}${PREFIX}/share/spice/helpdir
${BSD_INSTALL_SCRIPT} lib/scripts/setplot lib/scripts/spinit \