aboutsummaryrefslogtreecommitdiff
path: root/cad/systemc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/systemc/Makefile')
-rw-r--r--cad/systemc/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/cad/systemc/Makefile b/cad/systemc/Makefile
index ee9771f315fc..6697623bf914 100644
--- a/cad/systemc/Makefile
+++ b/cad/systemc/Makefile
@@ -6,15 +6,14 @@
#
PORTNAME= systemc
-PORTVERSION= 2.1.v1
-PORTREVISION= 1
+PORTVERSION= 2.2.0
CATEGORIES= cad devel
EXTRACT_SUFX= .tgz
MAINTAINER= dthiele@gmx.net
COMMENT= A modeling platform for system-level C++ models
-RESTRICTED= You have to register at http://www.systemc.org/account/register.php first
+RESTRICTED= You have to register at http://www.systemc.org/kmembership_info/individual_signup first
USE_GMAKE= yes
HAS_CONFIGURE= yes
@@ -28,7 +27,7 @@ INSTALL_WRKSRC= ${WRKSRC}/objdir
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
-IGNORE= is restricted. You have to register at http://www.systemc.org/account/register.php and download ${DISTFILES} from there first. Then put ${DISTFILES} into ${DISTDIR} and run make again
+IGNORE= is restricted. You have to register at http://www.systemc.org/kmembership_info/individual_signup and download ${DISTFILES} from http://www.systemc.org/downloads/standards/ first. Then put ${DISTFILES} into ${DISTDIR} and run make again
.endif
.if defined(WITH_OPTIMIZED_CFLAGS)
@@ -46,4 +45,7 @@ pre-configure:
@${REINPLACE_CMD} -e 's|\(OPT_CXXFLAGS="\).*"|\1${CXXFLAGS}"|g' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+post-patch:
+ @find ${WRKSRC} -name .DS_Store -delete
+
.include <bsd.port.post.mk>