aboutsummaryrefslogtreecommitdiff
path: root/cad/xcircuit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/xcircuit/Makefile')
-rw-r--r--cad/xcircuit/Makefile42
1 files changed, 13 insertions, 29 deletions
diff --git a/cad/xcircuit/Makefile b/cad/xcircuit/Makefile
index 11fd8086dab7..bb9dd0acb319 100644
--- a/cad/xcircuit/Makefile
+++ b/cad/xcircuit/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xcircuit
-PORTVERSION= 3.1.38
+PORTVERSION= 3.3.18
PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= http://xcircuit.ece.jhu.edu/archive/
@@ -14,6 +14,8 @@ MASTER_SITES= http://xcircuit.ece.jhu.edu/archive/
MAINTAINER= ports@FreeBSD.org
COMMENT= An X11 drawing program [especially for circuit schematics]
+LIB_DEPENDS= tk84:${PORTSDIR}/x11-toolkits/tk84
+
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_XPM= yes
@@ -22,26 +24,12 @@ USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
- AUTOHEADER="${TRUE}"
-
-WISH= ${LOCALBASE}/bin/wish8.4
-
-.if defined(WITH_TCLTK)
-PKGNAMESUFFIX= -tcltk
-LIB_DEPENDS+= tk84:${PORTSDIR}/x11-toolkits/tk84
CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.4 \
--with-tk=${LOCALBASE}/lib/tk8.4
-ALL_TARGET= tcl
-INSTALL_TARGET= install-tcl
-PLIST_SUB+= TCLTK="" NOTCLTK="@comment "
-CFLAGS+= -I${LOCALBASE}/include/tcl8.4 -I${LOCALBASE}/include/tk8.4 \
- -I${X11BASE}/include
-.else
-MAN1+= xcircuit.1
-PLIST_SUB+= TCLTK="@comment " NOTCLTK=""
-.endif
+
+CFLAGS+= -I${X11BASE}/include
+
+WISH= ${LOCALBASE}/bin/wish8.4
pre-everything::
.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
@@ -50,16 +38,12 @@ pre-everything::
@${ECHO_MSG} " AFPL Postscript interpreter instead of GNU one"
@${ECHO_MSG} ""
.endif
-.if !defined(WITH_TCLTK)
- @${ECHO_MSG} ""
- @${ECHO_MSG} " Define WITH_TCLTK for Tcl/Tk support"
- @${ECHO_MSG} " (prevents python support)"
- @${ECHO_MSG} ""
-.endif
post-patch:
- @${REINPLACE_CMD} -e 's|TCL_LIB_NAME=.*$$|TCL_LIB_NAME="tcl84"|g ; \
- s|TK_LIB_NAME=.*$$|TK_LIB_NAME="tk84"|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/test/s| == | = |g ; \
+ s|TCL_LIB_NAME=.*$$|TCL_LIB_NAME="tcl84"|g ; \
+ s|TK_LIB_NAME=.*$$|TK_LIB_NAME="tk84"|g ; \
+ s|-Wl,--version-script=|--version-script |g' ${WRKSRC}/configure
.for file in lib/tcl/xcircuit.sh.m4 lib/tcl/tkcon.tcl
@${REINPLACE_CMD} -e 's|exec wish|exec ${WISH}|g' ${WRKSRC}/${file}
.endfor
@@ -67,8 +51,8 @@ post-patch:
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}
- ${TAR} -C ${WRKSRC}/examples --exclude "CVS" --exclude "*.py" \
- -cf - . | ${TAR} -C ${EXAMPLESDIR} --unlink -xf -
+ ${TAR} -C ${WRKSRC}/examples --exclude "*.py" -cf - . | \
+ ${TAR} -C ${EXAMPLESDIR} --unlink -xf -
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.endif