aboutsummaryrefslogtreecommitdiff
path: root/cad/xcircuit
diff options
context:
space:
mode:
Diffstat (limited to 'cad/xcircuit')
-rw-r--r--cad/xcircuit/Makefile1
-rw-r--r--cad/xcircuit/files/patch-events.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/cad/xcircuit/Makefile b/cad/xcircuit/Makefile
index a618447d0be8..a57ad9be2486 100644
--- a/cad/xcircuit/Makefile
+++ b/cad/xcircuit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xcircuit
PORTVERSION= 3.3.33
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= http://xcircuit.ece.jhu.edu/archive/
diff --git a/cad/xcircuit/files/patch-events.c b/cad/xcircuit/files/patch-events.c
new file mode 100644
index 000000000000..58f0897eb19a
--- /dev/null
+++ b/cad/xcircuit/files/patch-events.c
@@ -0,0 +1,11 @@
+--- events.c.orig Thu Sep 8 22:33:01 2005
++++ events.c Wed Sep 14 14:11:38 2005
+@@ -2436,7 +2436,7 @@
+ pathptr rotatepath = SELTOPATH(selectobj);
+
+ register_for_undo(XCF_Edit, UNDO_MORE, areastruct.topinstance,
+- *rotatepath);
++ rotatepath);
+ for (genpart = rotatepath->plist; genpart < rotatepath->plist
+ + rotatepath->parts; genpart++)
+ elemrotate(genpart, direction);