aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
Diffstat (limited to 'cad')
-rw-r--r--cad/alliance/Makefile1
-rw-r--r--cad/freehdl/Makefile2
-rw-r--r--cad/meshlab/Makefile9
-rw-r--r--cad/repsnapper/Makefile7
4 files changed, 13 insertions, 6 deletions
diff --git a/cad/alliance/Makefile b/cad/alliance/Makefile
index 3de3e7d30124..acc97ec88783 100644
--- a/cad/alliance/Makefile
+++ b/cad/alliance/Makefile
@@ -18,6 +18,7 @@ LICENSE_FILE= ${WRKSRC}/LICENCE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BROKEN_aarch64= fails to link: collect2: error: ld returned 1 exit status
+BROKEN_powerpc64= fails to build: cc1plus: error: unrecognized command line option "-std=gnu++03"
CONFLICTS_INSTALL= fspclient-*
diff --git a/cad/freehdl/Makefile b/cad/freehdl/Makefile
index 0f87ad5031f9..562718ca7be9 100644
--- a/cad/freehdl/Makefile
+++ b/cad/freehdl/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= http://freehdl.seul.org/~enaroska/
MAINTAINER= ports@FreeBSD.org
COMMENT= Free VHDL simulator
+BROKEN_powerpc64= fails to build: cc1plus: error: unrecognized command line option "-std=gnu++03"
+
USES= gmake pathfix libtool makeinfo perl5 pkgconfig
USE_LDCONFIG= yes
USE_GCC= any
diff --git a/cad/meshlab/Makefile b/cad/meshlab/Makefile
index be87ff7bd0c4..6f859088c4f4 100644
--- a/cad/meshlab/Makefile
+++ b/cad/meshlab/Makefile
@@ -13,13 +13,16 @@ COMMENT= 3D triangular meshes processing and editing tool
LICENSE= GPLv2
+BROKEN_aarch64= fails to compile: constant expression evaluates to -1 which cannot be narrowed to type char
+BROKEN_armv6= fails to compile: constant expression evaluates to -1 which cannot be narrowed to type char
+BROKEN_armv7= fails to compile: constant expression evaluates to -1 which cannot be narrowed to type char
+BROKEN_powerpc64= fails to compile: mc_lookup_table.h:316:5: narrowing conversion of '-1' from 'int' to 'char' inside { }
+
EXTRACT_DEPENDS=gtar:archivers/gtar
LIB_DEPENDS= libQtSolutions_SOAP-head.so:devel/qt4-qtsolutions-soap \
libmpir.so:math/mpir
-BROKEN_aarch64= Fails to compile: constant expression evaluates to -1 which cannot be narrowed to type char
-
-USES= dos2unix qmake compiler:c++11-lib tar:tgz
+USES= compiler:c++11-lib dos2unix qmake tar:tgz
USE_CXXSTD= c++11
USE_GL= glew glu
USE_QT4= moc_build rcc_build uic_build corelib gui xml \
diff --git a/cad/repsnapper/Makefile b/cad/repsnapper/Makefile
index ad2f30bfb670..c1da5ce8b16b 100644
--- a/cad/repsnapper/Makefile
+++ b/cad/repsnapper/Makefile
@@ -12,15 +12,16 @@ COMMENT= Controller and GCode generator for RepRap 3D printers
LICENSE= GPLv2 BSD3CLAUSE MIT
LICENSE_COMB= multi
+BROKEN_powerpc64= fails to compile: clipper.hpp:52:10: 'vector' file not found
+
LIB_DEPENDS= libgtkglextmm-x11-1.2.so:x11-toolkits/gtkglextmm \
libpolyclipping.so:graphics/polyclipping \
libzip.so:archivers/libzip
-USE_GITHUB= yes
-GH_ACCOUNT= timschmidt
-
USES= compiler:c++11-lib autoreconf gettext gmake libtool localbase \
perl5 pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= timschmidt
USE_GNOME= gtkmm24 intltool libxml++26
USE_GL= gl
USE_PERL5= build