aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
Diffstat (limited to 'cad')
-rw-r--r--cad/Makefile1
-rw-r--r--cad/py-gdspy/Makefile29
-rw-r--r--cad/py-gdspy/distinfo3
-rw-r--r--cad/py-gdspy/pkg-descr5
4 files changed, 38 insertions, 0 deletions
diff --git a/cad/Makefile b/cad/Makefile
index e472ecfcc417..4c9fc02f76f0 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -62,6 +62,7 @@
SUBDIR += p5-Verilog-Perl
SUBDIR += pcb
SUBDIR += pdnmesh
+ SUBDIR += py-gdspy
SUBDIR += py-lcapy
SUBDIR += py-pycam
SUBDIR += pythoncad
diff --git a/cad/py-gdspy/Makefile b/cad/py-gdspy/Makefile
new file mode 100644
index 000000000000..76ccc0204ca7
--- /dev/null
+++ b/cad/py-gdspy/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= gdspy
+PORTVERSION= 0.8.1
+DISTVERSIONPREFIX= v
+CATEGORIES= cad python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Python module for creating GDSII stream files
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>0:math/py-numpy
+
+USES= python
+USE_PYTHON= distutils autoplist
+USE_GITHUB= yes
+GH_ACCOUNT= heitzmann
+
+OPTIONS_DEFINE= EXAMPLES
+EXAMPLES_PLIST_FILES= ${EXAMPLESDIR}/tutorial.py
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/tutorial.py \
+ ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/cad/py-gdspy/distinfo b/cad/py-gdspy/distinfo
new file mode 100644
index 000000000000..a966d689fbb7
--- /dev/null
+++ b/cad/py-gdspy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1463423238
+SHA256 (heitzmann-gdspy-v0.8.1_GH0.tar.gz) = d399b3c2740e2e0a9221b94aeaddc4f58aea69546e85e8753df15ea8eac5389d
+SIZE (heitzmann-gdspy-v0.8.1_GH0.tar.gz) = 107816
diff --git a/cad/py-gdspy/pkg-descr b/cad/py-gdspy/pkg-descr
new file mode 100644
index 000000000000..4b1679e0e603
--- /dev/null
+++ b/cad/py-gdspy/pkg-descr
@@ -0,0 +1,5 @@
+Gdspy is a Python module for creating GDSII stream files, usually CAD
+layouts. It includes a layout viewer for the geometries created, and
+it can also be used to import and merge GDSII files.
+
+WWW: https://github.com/heitzmann/gdspy