aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
Diffstat (limited to 'cad')
-rw-r--r--cad/tkgate/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/cad/tkgate/Makefile b/cad/tkgate/Makefile
index 6f323b4fda98..7b3efb72cfed 100644
--- a/cad/tkgate/Makefile
+++ b/cad/tkgate/Makefile
@@ -19,10 +19,14 @@ LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84
RUN_DEPENDS= tclsh8.4:${PORTSDIR}/lang/tcl84
BUILD_DEPENDS= xmkmf:${X_IMAKE_PORT}
-GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
USE_BISON= yes
USE_X_PREFIX= yes
PLIST_SUB= VERSION=${PORTVERSION}
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},g' \
+ ${WRKSRC}/Imakefile ${WRKSRC}/config.h
+
.include <bsd.port.mk>