aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
Diffstat (limited to 'cad')
-rw-r--r--cad/calculix/Makefile9
-rw-r--r--cad/feappv/Makefile3
-rw-r--r--cad/gmsh/Makefile5
-rw-r--r--cad/gmsh/files/patch-Fltk-Main.cpp11
-rw-r--r--cad/gmsh/files/patch-Mesh-meshGFaceBDS.cpp13
-rw-r--r--cad/gmsh/pkg-plist2
-rw-r--r--cad/sceptre/Makefile2
-rw-r--r--cad/scotch/Makefile2
8 files changed, 34 insertions, 13 deletions
diff --git a/cad/calculix/Makefile b/cad/calculix/Makefile
index 4b61958a54f7..51820ce005af 100644
--- a/cad/calculix/Makefile
+++ b/cad/calculix/Makefile
@@ -43,7 +43,8 @@ DIST_EXAMPLES= ccx_${PORTVERSION}.test${EXTRACT_SUFX} \
cgx_${PORTVERSION}.exa${EXTRACT_SUFX}
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_GMAKE= yes
+USES= fortran gmake
+USE_GCC= yes
USE_XORG= xmu
USE_GL= glut
@@ -54,7 +55,6 @@ CCX_VER= ccx_${PORTVERSION}
CGX_VER= cgx_2.6
NO_STAGE= yes
-.include <bsd.port.pre.mk>
.include <bsd.port.options.mk>
OPTIONS_DEFINE= METIS METIS_EDF
@@ -81,9 +81,6 @@ BLAS_LIBS= -lblas
LAPACK_LIBS= -llapack
.endif
-USE_FORTRAN= yes
-USE_GCC= yes
-
.if ${ARCH} == "sparc64"
CFLAGS+= -fPIC
FFLAGS+= -fPIC
@@ -148,4 +145,4 @@ do-install:
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/cad/feappv/Makefile b/cad/feappv/Makefile
index ea19b62441df..a06f70e6fc4a 100644
--- a/cad/feappv/Makefile
+++ b/cad/feappv/Makefile
@@ -13,10 +13,9 @@ EXTRACT_ONLY= ${PORTNAME}${PORTVERSION:S/.//}${EXTRACT_SUFX}
MAINTAINER= mexas@bris.ac.uk
COMMENT= Finite element analysis program (personal version)
-USES= gmake
+USES= fortran gmake
USE_ZIP= yes
USE_XORG= x11
-USE_FORTRAN= yes
MAKEFILE= makefile
MAKE_ENV= FEAPPVHOME3_1="${WRKSRC}"
ALL_TARGET= install
diff --git a/cad/gmsh/Makefile b/cad/gmsh/Makefile
index d12903e7d412..363a2fbcc471 100644
--- a/cad/gmsh/Makefile
+++ b/cad/gmsh/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gmsh
PORTVERSION= 2.8.4
+PORTREVISION= 1
CATEGORIES= cad
MASTER_SITES= http://www.geuz.org/gmsh/src/ \
http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis/
@@ -26,9 +27,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-source
SLAVEDIRS= cad/gmsh-occ
-USE_FORTRAN= yes
-USES= cmake
-USE_GMAKE= yes
+USES= cmake fortran gmake
USE_GL= yes
ALL_TARGET= all
diff --git a/cad/gmsh/files/patch-Fltk-Main.cpp b/cad/gmsh/files/patch-Fltk-Main.cpp
new file mode 100644
index 000000000000..d5ec754d8136
--- /dev/null
+++ b/cad/gmsh/files/patch-Fltk-Main.cpp
@@ -0,0 +1,11 @@
+--- Fltk/Main.cpp.orig
++++ Fltk/Main.cpp
+@@ -3,7 +3,7 @@
+ // See the LICENSE.txt file for license information. Please report all
+ // bugs and problems to the public mailing list <gmsh@geuz.org>.
+
+-#include <stdlib.h>
++#include <cstdlib>
+ #include <string>
+ #include "Gmsh.h"
+ #include "GmshMessage.h"
diff --git a/cad/gmsh/files/patch-Mesh-meshGFaceBDS.cpp b/cad/gmsh/files/patch-Mesh-meshGFaceBDS.cpp
new file mode 100644
index 000000000000..855c1939a918
--- /dev/null
+++ b/cad/gmsh/files/patch-Mesh-meshGFaceBDS.cpp
@@ -0,0 +1,13 @@
+--- Mesh/meshGFaceBDS.cpp.orig
++++ Mesh/meshGFaceBDS.cpp
+@@ -771,8 +771,8 @@
+ while (it != m.edges.end()){
+ BDS_Edge *e = *it;
+ if (!e->deleted && e->numfaces() == 2){
+- std::map<BDS_Point*, MVertex*>::iterator itp1 = recoverMap->find(e->p1);
+- std::map<BDS_Point*, MVertex*>::iterator itp2 = recoverMap->find(e->p2);
++ std::map<BDS_Point*, MVertex*, PointLessThan>::iterator itp1 = recoverMap->find(e->p1);
++ std::map<BDS_Point*, MVertex*, PointLessThan>::iterator itp2 = recoverMap->find(e->p2);
+ if (itp1 != recoverMap->end() &&
+ itp2 != recoverMap->end() &&
+ itp1->second == itp2->second) toSplit.insert(e);
diff --git a/cad/gmsh/pkg-plist b/cad/gmsh/pkg-plist
index 9ed8acaff405..77aabf76f383 100644
--- a/cad/gmsh/pkg-plist
+++ b/cad/gmsh/pkg-plist
@@ -63,6 +63,7 @@ include/gmsh/OptHomRun.h
include/gmsh/PView.h
include/gmsh/PViewData.h
include/gmsh/PViewDataGModel.h
+include/gmsh/PViewDataList.h
include/gmsh/PViewOptions.h
include/gmsh/Pair.h
include/gmsh/ParamCoord.h
@@ -103,6 +104,7 @@ include/gmsh/linearSystem.h
include/gmsh/linearSystemCSR.h
include/gmsh/linearSystemFull.h
include/gmsh/linearSystemGMM.h
+include/gmsh/linearSystemMUMPS.h
include/gmsh/linearSystemPETSc.h
include/gmsh/mathEvaluator.h
include/gmsh/mathex.h
diff --git a/cad/sceptre/Makefile b/cad/sceptre/Makefile
index f66f78a916bd..3e6e8721ee33 100644
--- a/cad/sceptre/Makefile
+++ b/cad/sceptre/Makefile
@@ -12,7 +12,7 @@ COMMENT= General-purpose circuit analysis program
LICENSE= GPLv2
-USE_FORTRAN= yes
+USES= fortran
MAKE_JOBS_UNSAFE= yes
NO_WRKSUBDIR= yes
diff --git a/cad/scotch/Makefile b/cad/scotch/Makefile
index 962eed11c7bc..70d8e161185c 100644
--- a/cad/scotch/Makefile
+++ b/cad/scotch/Makefile
@@ -22,7 +22,7 @@ USES= gmake
MAKE_JOBS_UNSAFE= yes
.if defined(MAINTAINER_MODE)
-USE_FORTRAN= yes
+USES+= fortran
.endif
WRKSRC= ${WRKDIR}/${DISTNAME:C/b_/_/}