aboutsummaryrefslogtreecommitdiff
path: root/chinese/bg5ps
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/bg5ps')
-rw-r--r--chinese/bg5ps/Makefile26
-rw-r--r--chinese/bg5ps/distinfo2
-rw-r--r--chinese/bg5ps/files/patch-aa56
-rw-r--r--chinese/bg5ps/pkg-descr15
-rw-r--r--chinese/bg5ps/pkg-message9
-rw-r--r--chinese/bg5ps/pkg-plist19
6 files changed, 81 insertions, 46 deletions
diff --git a/chinese/bg5ps/Makefile b/chinese/bg5ps/Makefile
index 1d1862c77305..ac5d5a941720 100644
--- a/chinese/bg5ps/Makefile
+++ b/chinese/bg5ps/Makefile
@@ -1,30 +1,36 @@
# New ports collection makefile for: bg5ps
-# Version required: 1.1b
+# Version required: 1.1b2
# Date created: 17 June 1998
-# Whom: J.T. Jang (keith@email.gcn.net.tw)
+# Whom: J.T. Jang (keith@freebsd.sinica.edu.tw)
#
# $FreeBSD$
#
-DISTNAME= bg5ps-1.1b
-PKGNAME= zh-bg5ps-1.1b
+DISTNAME= bg5ps-1.1b2
+PKGNAME= zh-bg5ps-1.1b2
CATEGORIES= chinese print
-MASTER_SITES= http://weber.u.washington.edu/~cschin/bg5ps/bg5ps-1.1b/
+MASTER_SITES= ftp://freebsd.sinica.edu.tw/pub/keith/ \
+ http://students.washington.edu/~cschin/bg5ps/bg5ps-1.1b2/
EXTRACT_SUFX= .tgz
-MAINTAINER= keith@email.gcn.net.tw
+MAINTAINER= keith@freebsd.sinica.edu.tw
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python:${PORTSDIR}/lang/python \
+ ${X11BASE}/lib/X11/fonts/TrueType/moe_kai.ttf:${PORTSDIR}/chinese/moettf
NO_WRKSUBDIR= yes
do-install:
@${MKDIR} ${PREFIX}/share/doc/bg5ps
+ @${MKDIR} ${PREFIX}/share/examples/bg5ps
${INSTALL_SCRIPT} ${WRKSRC}/bg5ps ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/ttf2psm ${PREFIX}/bin
-.for doc in README bg5ps.conf test.big5 test.sh ttf2ps.doc
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${PREFIX}/share/doc/bg5ps
-.endfor
+ ${CP} -R ${WRKSRC}/doc/* ${PREFIX}/share/doc/bg5ps
+ ${RM} ${PREFIX}/share/doc/bg5ps/COPYING.txt
+ ${INSTALL_DATA} ${WRKSRC}/bg5ps.conf ${PREFIX}/share/doc/bg5ps/bg5ps.conf
+ ${INSTALL_DATA} ${WRKSRC}/examples/netscape.ps ${PREFIX}/share/examples/bg5ps
+ ${INSTALL_DATA} ${WRKSRC}/examples/test.big5 ${PREFIX}/share/examples/bg5ps
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/test.sh ${PREFIX}/share/examples/bg5ps
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/chinese/bg5ps/distinfo b/chinese/bg5ps/distinfo
index 15ec800d477c..a4c6262d5b50 100644
--- a/chinese/bg5ps/distinfo
+++ b/chinese/bg5ps/distinfo
@@ -1 +1 @@
-MD5 (bg5ps-1.1b.tgz) = 45fb86c924887249c2970446e62098b4
+MD5 (bg5ps-1.1b2.tgz) = 2fac1a44f57a7dfb67f974af4484a2aa
diff --git a/chinese/bg5ps/files/patch-aa b/chinese/bg5ps/files/patch-aa
index 751404c47047..292c81914419 100644
--- a/chinese/bg5ps/files/patch-aa
+++ b/chinese/bg5ps/files/patch-aa
@@ -1,22 +1,43 @@
---- Makefile.orig Fri Jun 26 22:05:28 1998
-+++ Makefile Fri Jun 26 22:06:00 1998
-@@ -0,0 +1,5 @@
-+all:
-+ $(CC) $(CFLAGS) -o ttf2psm ttf2psm.c
-+
-+clean:
-+ -@rm ttf2psm
---- bg5ps.orig Mon Dec 8 15:28:30 1997
-+++ bg5ps Wed Jun 17 13:08:09 1998
+--- bg5ps.orig Fri Oct 2 08:35:41 1998
++++ bg5ps Fri Dec 17 17:01:21 1999
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/local/bin/python
################################################################################
# bg5ps.py which use the ttf2ps program to convert the Big5 Coding chinese #
# text into printable postscript file. Since it uses true type font, the #
---- ttf2psm.c.orig Mon Dec 8 03:57:58 1997
-+++ ttf2psm.c Wed Jun 17 13:35:48 1998
-@@ -6,7 +6,6 @@
+@@ -418,10 +418,10 @@
+ exec l
+ cf.close()
+ else:
+- sys.stderr.write("\n~/.bg5ps.conf not found.\n Trying /etc/bg5ps.conf.")
+- if os.path.isfile("/etc/bg5ps.conf"):
+- sys.stderr.write("\n /etc/bg5ps.conf found. Use configuration file /etc/bg5ps.conf")
+- cf=open("/etc/bg5ps.conf","r")
++ sys.stderr.write("\n~/.bg5ps.conf not found.\n Trying /usr/local/etc/chinese/bg5ps.conf.")
++ if os.path.isfile("/usr/local/etc/chinese/bg5ps.conf"):
++ sys.stderr.write("\n /usr/local/etc/chinese/bg5ps.conf found. Use configuration file /usr/local/etc/chinese/bg5ps.conf")
++ cf=open("/usr/local/etc/chinese/bg5ps.conf","r")
+ for l in cf.readlines():
+ exec l
+ cf.close()
+--- bg5ps.conf.orig Fri Dec 17 16:58:30 1999
++++ bg5ps.conf Fri Dec 17 17:07:48 1999
+@@ -1,9 +1,9 @@
+ #chineseFontPath: 指定中文字型的路徑(預設值: 與 bg5ps 同)
+-chineseFontPath=""
++chineseFontPath="/usr/X11R6/lib/X11/fonts/TrueType"
+ #modify the above line
+
+ #fontName: 指定中文字型的檔案名稱(預設值: ntu_kai)
+-fontName="ntu_kai"
++fontName="moe_kai"
+
+ #oddPages: 0 不輸出奇數頁,1 輸出奇數頁(預設值: 1)
+ #true=1, false=0
+--- ttf2psm.c.orig Wed Aug 26 21:50:26 1998
++++ ttf2psm.c Fri Dec 17 17:03:31 1999
+@@ -10,7 +10,6 @@
#include <math.h>
#include <stdlib.h>
#include <string.h>
@@ -24,3 +45,12 @@
#include <memory.h>
#include <time.h>
+@@ -96,7 +95,7 @@
+ void Beg();
+ void End();
+
+-void main(int argc, char *argv[]){
++int main(int argc, char *argv[]){
+ FILE *fn;
+ short cidx, i;
+ time_t t1, t2;
diff --git a/chinese/bg5ps/pkg-descr b/chinese/bg5ps/pkg-descr
index 4d336377cbff..010e0113ef02 100644
--- a/chinese/bg5ps/pkg-descr
+++ b/chinese/bg5ps/pkg-descr
@@ -1,17 +1,2 @@
bg5ps is a Python script that generates Postscript from a Chinese Big5
encoded file. You have to specify the TTF font path (default: ~/.bg5ps.conf).
-
-bg5ps -fp fontpath -fn fontname
- -o [1|0] -e [1|0]
- -s size -ls linespacing -cs charspacing
- -tm topMargin -bm bottomMargin -lm leftMargin -rm rightMargin
- -if inputfile -of outputfile
- -cp configFilePath
-Size, linespacing, charspacing, and margins are numbers in unit of pt=1/72 in.
-
-bg5ps -h: print this help
-or
-cat big5text | bg5ps options > outputfile
-
-Example:
-bg5ps -fn kai -o 1 -e 0 -s 15 -ls 10 -cs 2 -tm 72 -bm 72 -if test -of test.ps
diff --git a/chinese/bg5ps/pkg-message b/chinese/bg5ps/pkg-message
index 2d7a61b1cfe0..ef1f2f76b1e6 100644
--- a/chinese/bg5ps/pkg-message
+++ b/chinese/bg5ps/pkg-message
@@ -1,5 +1,6 @@
------------------------------------------------------------
-Copy ${PREFIX}/share/doc/bg5ps/bg5ps.conf to ~/.bg5ps.conf.
-Then run "bg5ps -h" for help.
------------------------------------------------------------
+
+------------------------------------------------------------
+Copy /usr/local/share/doc/bg5ps/bg5ps.conf to ~/.bg5ps.conf.
+Then modify it to suit your needs.
+------------------------------------------------------------
diff --git a/chinese/bg5ps/pkg-plist b/chinese/bg5ps/pkg-plist
index a4f6d0e23a86..86dba3bcfda0 100644
--- a/chinese/bg5ps/pkg-plist
+++ b/chinese/bg5ps/pkg-plist
@@ -1,8 +1,21 @@
bin/bg5ps
bin/ttf2psm
-share/doc/bg5ps/README
share/doc/bg5ps/bg5ps.conf
-share/doc/bg5ps/test.big5
-share/doc/bg5ps/test.sh
+share/doc/bg5ps/bg5ps.sgml
+share/doc/bg5ps/bg5ps.txt
+share/doc/bg5ps/html/bg5ps.html
+share/doc/bg5ps/html/bg5ps-1.html
+share/doc/bg5ps/html/bg5ps-2.html
+share/doc/bg5ps/html/bg5ps-3.html
+share/doc/bg5ps/html/bg5ps-4.html
+share/doc/bg5ps/html/bg5ps-5.html
+share/doc/bg5ps/html/bg5ps-6.html
+share/doc/bg5ps/html/bg5ps-7.html
+share/doc/bg5ps/makeps
share/doc/bg5ps/ttf2ps.doc
+share/examples/bg5ps/netscape.ps
+share/examples/bg5ps/test.big5
+share/examples/bg5ps/test.sh
+@dirrm share/doc/bg5ps/html
@dirrm share/doc/bg5ps
+@dirrm share/examples/bg5ps