aboutsummaryrefslogtreecommitdiff
path: root/chinese/fireflyttf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/fireflyttf/Makefile')
-rw-r--r--chinese/fireflyttf/Makefile34
1 files changed, 16 insertions, 18 deletions
diff --git a/chinese/fireflyttf/Makefile b/chinese/fireflyttf/Makefile
index ee7a4eee8332..4a27ba8012de 100644
--- a/chinese/fireflyttf/Makefile
+++ b/chinese/fireflyttf/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= fireflyttf
-PORTVERSION= 1.1.0
-PORTREVISION= 1
+PORTVERSION= 1.2.6
+PORTREVISION= 0
CATEGORIES= chinese x11-fonts
MASTER_SITES= http://www.study-area.org/apt/firefly-font/
DISTNAME= fireflysung.ttf
@@ -16,28 +16,26 @@ EXTRACT_SUFX= .gz
MAINTAINER= statue@freebsd.sinica.edu.tw
COMMENT= Firefly TrueType Font is combine of two arphic sung fonts
-BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig \
- ttfm.sh:${PORTSDIR}/chinese/ttfm
-RUN_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig \
- ttfm.sh:${PORTSDIR}/chinese/ttfm
-
NO_BUILD= yes
WRKSRC= ${WRKDIR}
-USE_XLIB= yes
-FONTDIR= ${PREFIX}/share/fonts/TrueType
-XFONTDIR= ${X11BASE}/lib/X11/fonts/TrueType
EXTRACT_AFTER_ARGS= > ${DISTNAME}
-.include <bsd.port.pre.mk>
+TTF= ${DISTNAME}
+
+.if !defined(WITHOUT_X11)
+PLIST_SUB+= X11=""
+.else
+PLIST_SUB+= X11="@comment "
+.endif
do-install:
- @${MKDIR} ${FONTDIR}
- @${INSTALL_DATA} ${WRKSRC}/${DISTNAME} ${FONTDIR}
- @${ECHO_MSG} "===> Running ttfm.sh"
- -@${PREFIX}/bin/ttfm.sh --add xttfm ${DISTNAME}
- @${ECHO_MSG} "===> Running fc-cache"
- -@${X11BASE}/bin/fc-cache -f -v ${XFONTDIR}
- ${INSTALL_DATA} ${FILESDIR}/local.conf-sung ${FONTDIR}
+ ${MKDIR} ${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${TTF} ${FONTSDIR}
+ ${INSTALL_DATA} ${FILESDIR}/local.conf-sung ${FONTSDIR}
+.if !defined(WITHOUT_X11)
${INSTALL_DATA} ${FILESDIR}/local.conf-sung ${X11BASE}/etc/fonts/local.conf
+.endif
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/chinese/ttfm/Makefile.ttf"
.include <bsd.port.post.mk>