aboutsummaryrefslogtreecommitdiff
path: root/chinese/gbfs
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/gbfs')
-rw-r--r--chinese/gbfs/Makefile74
-rw-r--r--chinese/gbfs/distinfo3
-rw-r--r--chinese/gbfs/files/gbfs.sh38
-rw-r--r--chinese/gbfs/pkg-descr5
-rw-r--r--chinese/gbfs/pkg-plist5
5 files changed, 0 insertions, 125 deletions
diff --git a/chinese/gbfs/Makefile b/chinese/gbfs/Makefile
deleted file mode 100644
index 7a39eaaaf645..000000000000
--- a/chinese/gbfs/Makefile
+++ /dev/null
@@ -1,74 +0,0 @@
-# New ports collection makefile for: zh-gbfs
-# Date created: Oct 13, 2000
-# Whom: statue@freebsd.sinica.edu.tw
-#
-# $FreeBSD$
-#
-
-PORTNAME= gbfs
-PORTVERSION= 1.4
-CATEGORIES= chinese
-MASTER_SITES= ftp://freebsd.sinica.edu.tw/pub/statue/gbfs/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Reads GB2312 filenames on Joliet and VFAT filesystems
-
-NO_PACKAGE= "Different versions definitely cause crash"
-
-SYSDIR= /usr/src/sys
-KMODDIR= ${PREFIX}/modules
-PLIST_SUB= MSDOSFSKO=${MSDOSFSKO}
-NO_WRKSUBDIR= yes
-
-DEPRECATED= Use mount_cd9660(8), mount_msdosfs(8), or mount_ntfs(8) instead
-EXPIRATION_DATE= 2007-03-14
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500000
-MSDOSFSDIR= ${SYSDIR}/fs/msdosfs
-MSDOSFSKO= msdosfs.ko
-MSDOSFSKODIR= ${SYSDIR}/modules/msdosfs
-MSDOSFSPATCH= msdosfs.diff.5
-CD9660PATCH= cd9660.diff.5
-NTFSDIR= ${SYSDIR}/fs/ntfs
-NTFSPATCH= ntfs.diff.5
-BROKEN= "fails to patch - Included patches are broken"
-.else
-MSDOSFSDIR= ${SYSDIR}/msdosfs
-MSDOSFSKO= msdos.ko
-MSDOSFSKODIR= ${SYSDIR}/modules/msdos
-MSDOSFSPATCH= msdosfs.diff
-CD9660PATCH= cd9660.diff
-NTFSDIR= ${SYSDIR}/ntfs
-NTFSPATCH= ntfs.diff
-.endif
-
-.if !exists (${SYSDIR})
-IGNORE= "You need to extract kernel source tree before you build this package"
-.endif
-
-do-extract:
- @${MKDIR} ${WRKSRC}/msdos ${WRKSRC}/cd9660 ${WRKSRC}/ntfs
- @${CP} -r ${MSDOSFSDIR}/* ${MSDOSFSKODIR}/Makefile ${WRKSRC}/msdos
- @${CP} -r ${SYSDIR}/isofs/cd9660/* ${SYSDIR}/modules/cd9660/Makefile ${WRKSRC}/cd9660
- @${CP} -r ${NTFSDIR}/* ${SYSDIR}/modules/ntfs/Makefile ${WRKSRC}/ntfs
- @(cd ${WRKSRC}; ${TAR} xzf ${DISTDIR}/${DISTFILES} )
- @${REINPLACE_CMD} -e "/^\.PATH/d" ${WRKSRC}/*/Makefile
-
-do-patch:
- @(cd ${WRKSRC}/msdos; ${PATCH} --quiet < ${WRKSRC}/${MSDOSFSPATCH} )
- @(cd ${WRKSRC}/cd9660; ${PATCH} --quiet < ${WRKSRC}/${CD9660PATCH} )
- @(cd ${WRKSRC}/ntfs; ${PATCH} --quiet < ${WRKSRC}/${NTFSPATCH} )
-
-do-build:
- @(cd ${WRKSRC}/msdos; make all)
- @(cd ${WRKSRC}/cd9660; make all)
- @(cd ${WRKSRC}/ntfs; make all)
-
-do-install:
- @${MKDIR} ${KMODDIR}
- @${INSTALL_SCRIPT} ${FILESDIR}/gbfs.sh ${PREFIX}/etc/rc.d
- @${INSTALL_SCRIPT} ${WRKSRC}/*/*.ko ${KMODDIR}
-
-.include <bsd.port.post.mk>
diff --git a/chinese/gbfs/distinfo b/chinese/gbfs/distinfo
deleted file mode 100644
index 90d080b96609..000000000000
--- a/chinese/gbfs/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (gbfs-1.4.tar.gz) = 22a72b1a6d9145d88fe89b7bcb367a2e
-SHA256 (gbfs-1.4.tar.gz) = 7e58427a52523867f0e22b470f7b7deeeb82edd6502fe300fcb42d003217e7f7
-SIZE (gbfs-1.4.tar.gz) = 89069
diff --git a/chinese/gbfs/files/gbfs.sh b/chinese/gbfs/files/gbfs.sh
deleted file mode 100644
index 2eff687f8fef..000000000000
--- a/chinese/gbfs/files/gbfs.sh
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/bin/sh
-
-if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
- echo "$0: Cannot determine the PREFIX" >&2
- exit 1
-fi
-
-case "$1" in
-start)
- if [ -x ${PREFIX}/modules/cd9660.ko ]; then
- echo -n ' GB-cd9660'
- kldload /usr/local/modules/cd9660.ko
- fi
- if [ -x ${PREFIX}/modules/msdos.ko ]; then
- echo -n ' GB-msdos'
- kldload /usr/local/modules/msdos.ko
- fi
- # msdosfs.ko instead of msdos.ko after FreeBSD 5.0-CURRENT
- if [ -x ${PREFIX}/modules/msdosfs.ko ]; then
- echo -n ' GB-msdosfs'
- kldload /usr/local/modules/msdosfs.ko
- fi
- if [ -x ${PREFIX}/modules/ntfs.ko ]; then
- echo -n ' GB-ntfs'
- kldload /usr/local/modules/ntfs.ko
- fi
- ;;
-stop)
- kldunload -v -n cd9660 && echo -n ' GB-cd9660'
- kldunload -v -n msdos && echo -n ' GB-msdos'
- kldunload -v -n msdosfs && echo -n ' GB-msdosfs'
- kldunload -v -n ntfs && echo -n ' GB-ntfs'
- ;;
-*)
- echo "Usage: $0 {start|stop}" >&2
- exit 1
- ;;
-esac
diff --git a/chinese/gbfs/pkg-descr b/chinese/gbfs/pkg-descr
deleted file mode 100644
index f1a5ab08f9ab..000000000000
--- a/chinese/gbfs/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-This port installs three kernel modules, cd9660.ko, msdos.ko and
-ntfs.ko, which will let users read GB2312 filenames on Joliet and VFAT
-filesystems, respectively.
-
-The Joliet, VFAT version is contributed by: cjacker@263.net
diff --git a/chinese/gbfs/pkg-plist b/chinese/gbfs/pkg-plist
deleted file mode 100644
index 583756e02836..000000000000
--- a/chinese/gbfs/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-etc/rc.d/gbfs.sh
-modules/cd9660.ko
-modules/%%MSDOSFSKO%%
-modules/ntfs.ko
-@dirrmtry modules